Closed Bug 1195795 Opened 4 years ago Closed 4 years ago

Google Docs stops working (CustomError: Error in protected function: Operation is not supported <unknown>)

Categories

(Core :: DOM: CSS Object Model, defect)

Unspecified
Windows 7
defect
Not set

Tracking

()

VERIFIED WORKSFORME
Tracking Status
firefox41 --- verified
firefox42 --- verified
firefox43 --- verified

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression, site-compat)

originally reported in Bug 1195030 comment Comment 16

In Dev Edition as of 2015-08-18 (which should have the backout?), I'm seeing a very similar error which is preventing me from creating new documents in Google Docs:

CustomError: Error in protected function: Operation is not supported <unknown>
(4x)

and then Google Docs says "Something went wrong; try reloading". Disabling e10s makes no difference.


Steps To Reproduce:
1. Go to https://www.google.com/intl/en/docs/about/ and sign-in
2. Open a document

Actual Results:
 Fails to load Google Docs with an alert message "This error has been reported to  Google and we'll look into it as soon as possible. Please reload this page to continue."


 The following errors are shown in Browser console.

  CustomError: Error in protected function: Operation is not supported <unknown>

  NotSupportedError: Operation is not supported 14875690-kix_main_i18n_kix_core__ja.js:1700:0

  TypeError: this.j is undefined 14875690-kix_main_i18n_kix_core__ja.js:1620:323


Expected Results:
 Document should open successfully. 


Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0574b7cd8e72&tochange=502e1a5e722f

Triggered by:
502e1a5e722f	ffxbld — Update configs. IGNORE BROKEN CHANGESETS CLOSED TREE NO BUG a=release ba=release


Further more bisect with UA spoofing "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

Regression window(m-c):
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6c2e4e4eb8ef&tochange=c20f8549d631

Regression window(m-i):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=aca9840cf06f&tochange=8476f8a5e00b

Regressed by: Bug 1088437
And further more bisect with UA spoofing "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0" and layout.css.font-loading-api.enabled=true

Regression window(m-i):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0e9883d2467b&tochange=109ae9a694cc

Regressed by: Bug 1028497
Blocks: 1028497
Flags: needinfo?(cam)
OS: Unspecified → Windows 7
For me, disabling layout.css.font-loading-api.enabled resolves issue
FYI: 41.0b1 has the same issue, started yesterday.
FYI: disabling the layout.css.font-loading-api.enabled pref also solved it for me.
I can't seem to reproduce this locally.  From the console messages in comment 0, I'm guessing we are throwing a NOT_SUPPORTED_ERR exception here:

  https://dxr.mozilla.org/mozilla-central/source/layout/style/FontFaceSet.cpp#407

Alice (or someone else experiencing the problem), can you confirm that?
Flags: needinfo?(cam) → needinfo?(alice0775)
John, if that is the problem, then we might have to take bug 1163877 after all.
Yes, I cannot reproduce the problem any more on Nightly43.0a11 Aurora42.0a2 and 40.0b1.

It seems Google has changed their code.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(alice0775)
Resolution: --- → WORKSFORME
I can confirm  that problem was fixed.
You need to log in before you can comment on or make changes to this bug.