Gmail Undo does not work currently in Nightly

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Bryan Price, Unassigned)

Tracking

Firefox 43

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150817061040

Steps to reproduce:

Go to Gmail.  Send an email, usually inadvertently, and ...


Actual results:

No Undo Send button even though it is set and set high enough (30 seconds) to be around.


Expected results:

I should have seen an Undo button with time enough to cancel the email.

This MAY be a Google bug, and I have sent multiple feedbacks on this to them, no reply of course.  But I have noticed this happening today.  But it's annoying enough now, and in the past, that I'm filing a bug, even if it gets marked WONTFIX.

Comment 1

3 years ago
Did you find this on other browsers too ?
Flags: needinfo?(bytehead)
(Reporter)

Comment 2

3 years ago
I'm only seeing this in the Nightly series.  When I go back and check the release, it always works for me.

For instance, today I'm seeing the undo button in the Nightly.  My current build.  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150819030206 CSet: f384789a29dcfd514d25d4a16a97ec5309612d78  It comes, and it goes, and I'm a bit frustrated with it.  And since I'm not sending email every day, I'm not really paying attention to make sure that every Nightly is consistent.  And for all I know, it's something that Google is tweaking.

I will setup a task to test this after every update and see if I can see a pattern or something, testing both the Nightly and the Release and see if there is a pattern and maybe lock down what is changing that causes it to work and then not work.

Of course, we just had a change from 42.0 to 43.0.  If Google is being a bit too promiscuous with the user agent, that might be the cause of my problem right there, because Google has to add the latest user agent string in its code to deal with the influx of Nightly users upgrading.  I will track for a week or so, and report back.  If it is working consistently, then I'll see if it disappears during the upgrade period from 43.0 to 44.0.  And if so, I'll see what happens when I change my user agent back to 43.0.  And if that fixes the problem, then it's on Google, but at least I'll know what I have to change to make it work like I want.
Flags: needinfo?(bytehead)

Updated

3 years ago
Component: Untriaged → Desktop
Product: Firefox → Tech Evangelism
Version: 43 Branch → Firefox 43
I've never even seen this "Undo" message - tested in Chrome a moment ago. Here I just get a "Message was sent. View message" yellow notification. Is this undo a feature you enable somewhere?
Flags: needinfo?(bytehead)
(Reporter)

Comment 4

3 years ago
Yes, it is a setting in Gmail.  This used to be a Lab, but it's been around for a few years, and Google has finally released it to the world (although what the difference is, I dunno, it's just an option in a different place...).  

Go to Settings and the General tab.  You will find an Undo Send section that you have to select to actually use, and then you can set it for however many seconds it stays around.  And I have mine set for 30 seconds. :p

I don't use it everyday (I don't even send email everyday, I just read it everyday...), but I find it quite useful, because I might catch something at the last second, or I get a cat deciding that they want something from me and jump on my keyboard.  Or I just fumble my fingers, and manage to send something incomplete.
Flags: needinfo?(bytehead)
A useful feature indeed - I'm enabling it on all accounts, for those cases when I hit ctrl-enter prematurely by mistake :)

I haven't seen it fail yet. Just tested again in Nightly on Ubuntu.
I tested this in a few versions on OSX and Linux but cannot reproduce. I'm going to close it as WFM for now, but if the issue comes back please let us know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.