Closed Bug 1196084 Opened 5 years ago Closed 5 years ago

Intermittent test_waveShaperPassThrough.html | application crashed [@ mozilla::AssertNotAlreadyCached]

Categories

(Core :: Audio/Video: Playback, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1187204
Tracking Status
firefox43 --- affected

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: assertion, crash, intermittent-failure)

16:45:54 INFO - Attempt to add a bool pref cache for preference 'dom.audiochannel.mutedByDefault' at address '06C230E8'was made. However, a pref was already cached at this address.
16:45:55 INFO - Assertion failure: false (Should not have an existing pref cache for this address), at c:/builds/moz2_slave/m-cen-w32-d-000000000000000000/build/src/modules/libpref/Preferences.cpp:216
16:45:55 INFO - #01: mozilla::Preferences::AddBoolVarCache(bool *,char const *,bool) [modules/libpref/Preferences.cpp:1745]
16:45:55 INFO - #02: mozilla::dom::AudioChannelService::AudioChannelService() [dom/audiochannel/AudioChannelService.cpp:227]
16:45:55 INFO - #03: mozilla::dom::AudioChannelService::GetOrCreate() [dom/audiochannel/AudioChannelService.cpp:170]
16:45:55 INFO - #04: mozilla::dom::AudioChannelAgent::NotifyStoppedPlaying(unsigned int) [dom/audiochannel/AudioChannelAgent.cpp:159]
16:45:55 INFO - #05: mozilla::dom::AudioDestinationNode::DestroyAudioChannelAgent() [dom/media/webaudio/AudioDestinationNode.cpp:392]
16:45:55 INFO - #06: mozilla::dom::AudioNode::cycleCollection::Unlink(void *) [dom/media/webaudio/AudioNode.cpp:25]
16:45:55 INFO - #07: mozilla::dom::AudioDestinationNode::cycleCollection::Unlink(void *) [dom/media/webaudio/AudioDestinationNode.cpp:320]
16:45:55 INFO - #08: nsCycleCollector::CollectWhite() [xpcom/base/nsCycleCollector.cpp:3276]
16:45:55 INFO - #09: nsCycleCollector::Collect(ccType,js::SliceBudget &,nsICycleCollectorListener *,bool) [xpcom/base/nsCycleCollector.cpp:3630]
16:45:55 INFO - #10: nsCycleCollector::ShutdownCollect() [xpcom/base/nsCycleCollector.cpp:3548]
16:45:55 INFO - #11: nsCycleCollector_shutdown() [xpcom/base/nsCycleCollector.cpp:4164]
16:45:55 INFO - #12: mozilla::ShutdownXPCOM(nsIServiceManager *) [xpcom/build/XPCOMInit.cpp:952]
16:45:55 INFO - #13: ScopedXPCOMStartup::~ScopedXPCOMStartup() [toolkit/xre/nsAppRunner.cpp:1498]
16:45:55 INFO - #14: mozilla::DefaultDelete<ScopedXPCOMStartup>::operator()(ScopedXPCOMStartup *) [mfbt/UniquePtr.h:490]
16:45:55 INFO - #15: XREMain::XRE_main(int,char * * const,nsXREAppData const *) [toolkit/xre/nsAppRunner.cpp:4416]
16:45:55 INFO - #16: XRE_main [toolkit/xre/nsAppRunner.cpp:4478]
16:45:55 INFO - #17: do_main [browser/app/nsBrowserApp.cpp:212]
16:45:55 INFO - #18: NS_internal_main(int,char * *) [browser/app/nsBrowserApp.cpp:399]
16:45:55 INFO - #19: wmain [toolkit/xre/nsWindowsWMain.cpp:138]
16:45:55 INFO - #20: __tmainCRTStartup [f:/dd/vctools/crt/crtw32/startup/crt0.c:255]
16:45:55 INFO - #21: kernel32 + 0x17067
16:45:55 INFO - TEST-INFO | Main app process: exit 1
16:45:55 INFO - 4302 INFO TEST-START | Shutdown
16:45:55 INFO - 4303 INFO Passed: 302043
16:45:55 INFO - 4304 INFO Failed: 0
16:45:55 INFO - 4305 INFO Todo: 25713
16:45:55 INFO - 4306 INFO Slowest: 89898ms - /tests/dom/events/test/test_wheel_default_action.html
16:45:55 INFO - 4307 INFO SimpleTest FINISHED
16:45:55 INFO - 4308 INFO TEST-INFO | Ran 1 Loops
16:45:55 INFO - 4309 INFO SimpleTest FINISHED
16:45:55 WARNING - TEST-UNEXPECTED-FAIL | dom/media/webaudio/test/test_waveShaperPassThrough.html | application terminated with exit code 1
16:45:55 INFO - runtests.py | Application ran for: 0:43:23.417000
16:45:55 INFO - zombiecheck | Reading PID log: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpwf7z9dpidlog
16:45:55 INFO - ==> process 1112 launched child process 3520 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel="1112.4.262710365\1226898239" "c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpcwlhra.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 1112 "\\.\pipe\gecko-crash-server-pipe.1112" plugin)
16:45:55 INFO - ==> process 1112 launched child process 1884 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel="1112.5.1434030712\1509243062" "c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpcwlhra.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 1112 "\\.\pipe\gecko-crash-server-pipe.1112" plugin)
16:46:08 INFO - mozcrash Saved minidump as C:\slave\test\build\blobber_upload_dir\88b96f9c-1be5-46b1-82a8-29076f9232af.dmp
16:46:08 INFO - mozcrash Saved app info as C:\slave\test\build\blobber_upload_dir\88b96f9c-1be5-46b1-82a8-29076f9232af.extra
16:46:08 WARNING - PROCESS-CRASH | dom/media/webaudio/test/test_waveShaperPassThrough.html | application crashed [@ mozilla::AssertNotAlreadyCached]
16:46:08 INFO - Crash dump filename: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpcwlhra.mozrunner\minidumps\88b96f9c-1be5-46b1-82a8-29076f9232af.dmp
16:46:08 INFO - Operating system: Windows NT
16:46:08 INFO - 5.1.2600 Service Pack 3
16:46:08 INFO - CPU: x86
16:46:08 INFO - GenuineIntel family 6 model 30 stepping 5
16:46:08 INFO - 8 CPUs
16:46:08 INFO - Crash reason: EXCEPTION_BREAKPOINT
16:46:08 INFO - Crash address: 0x3280a9b
16:46:08 INFO - Process uptime: 2603 seconds
16:46:08 INFO - Thread 0 (crashed)
16:46:08 INFO - 0 xul.dll!mozilla::AssertNotAlreadyCached [Preferences.cpp:db4616cd0721 : 216 + 0x18]
16:46:08 INFO - eip = 0x03280a9b esp = 0x0012f9b8 ebp = 0x0012f9bc ebx = 0x00000000
16:46:08 INFO - esi = 0x000000d8 edi = 0x06c230e8 eax = 0x00000000 ecx = 0x002b0ad9
16:46:08 INFO - edx = 0x00370ea0 efl = 0x00200206
16:46:08 INFO - Found by: given as instruction pointer in context
16:46:08 INFO - 1 xul.dll!mozilla::Preferences::AddBoolVarCache(bool *,char const *,bool) [Preferences.cpp:db4616cd0721 : 1743 + 0xe]
16:46:08 INFO - eip = 0x03280224 esp = 0x0012f9c4 ebp = 0x0012f9dc
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 2 xul.dll!mozilla::dom::AudioChannelService::AudioChannelService() [AudioChannelService.cpp:db4616cd0721 : 227 + 0x10]
16:46:08 INFO - eip = 0x04ab09de esp = 0x0012f9e4 ebp = 0x0012fa04
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 3 xul.dll!mozilla::dom::AudioChannelService::GetOrCreate() [AudioChannelService.cpp:db4616cd0721 : 170 + 0x14]
16:46:08 INFO - eip = 0x04ab1c2b esp = 0x0012fa0c ebp = 0x0012fa10
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 4 xul.dll!mozilla::dom::AudioChannelAgent::NotifyStoppedPlaying(unsigned int) [AudioChannelAgent.cpp:db4616cd0721 : 159 + 0xa]
16:46:08 INFO - eip = 0x04ab24a5 esp = 0x0012fa18 ebp = 0x0012fa28
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 5 xul.dll!mozilla::dom::AudioDestinationNode::DestroyAudioChannelAgent() [AudioDestinationNode.cpp:db4616cd0721 : 391 + 0xf]
16:46:08 INFO - eip = 0x048129f4 esp = 0x0012fa30 ebp = 0x0012fa68
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 6 xul.dll!mozilla::dom::AudioDestinationNode::DestroyMediaStream() [AudioDestinationNode.cpp:db4616cd0721 : 399 + 0x5]
16:46:08 INFO - eip = 0x04812a4d esp = 0x0012fa40 ebp = 0x0012fa68
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 7 xul.dll!mozilla::dom::AudioNode::DisconnectFromGraph() [AudioNode.cpp:db4616cd0721 : 190 + 0xa]
16:46:08 INFO - eip = 0x048130e7 esp = 0x0012fa4c ebp = 0x0012fa68
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 8 xul.dll!mozilla::dom::AudioNode::cycleCollection::Unlink(void *) [AudioNode.cpp:db4616cd0721 : 24 + 0x7]
16:46:08 INFO - eip = 0x0481b431 esp = 0x0012fa70 ebp = 0x0012fa7c
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 9 xul.dll!mozilla::dom::AudioDestinationNode::cycleCollection::Unlink(void *) [AudioDestinationNode.cpp:db4616cd0721 : 320 + 0x1a]
16:46:08 INFO - eip = 0x0481b3c9 esp = 0x0012fa84 ebp = 0x0012fa90
16:46:08 INFO - Found by: call frame info
16:46:08 INFO - 10 xul.dll!nsCycleCollector::CollectWhite() [nsCycleCollector.cpp:db4616cd0721 : 3274 + 0x8]
16:46:08 INFO - eip = 0x031ec454 esp = 0x0012fa98 ebp = 0x0012faec
16:46:08 INFO - Found by: call frame info
Blocks: 1162003
Component: Audio/Video → Audio/Video: Playback
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1187204
You need to log in before you can comment on or make changes to this bug.