Crash when switching between home panels rapidly

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sleroux, Assigned: sleroux)

Tracking

({crash})

unspecified
All
iOS
crash

Firefox Tracking Flags

(fxios+)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
STR:

1. Tap URL bar to bring up Home panels
2. Start tapping between the different home panels

Expected:

App should display each panel when tapped

Actual:

App will crash after a short time

-- 

Here is a partially symbolicated crash from crash-stats:

https://crash-stats.mozilla.com/report/index/798d3053-872b-4d47-b266-222d62150819

I'm currently in the process of trying to get the UIKit framework symbols loaded as well.
(Assignee)

Comment 1

3 years ago
Note: This occurred in build #36 Aurora
tracking-fxios: ? → 1.1+
How often is this reproducible?
(Assignee)

Comment 4

3 years ago
100% of the time when switching between panels quick. I might have narrowed it down. The issue as introduced between builds 34->35. I'm going to take this to see if there is a quick fix for 1.0 because crashes suck.
(Assignee)

Updated

3 years ago
Assignee: nobody → sleroux
(Assignee)

Comment 5

3 years ago
Created attachment 8650087 [details] [review]
https://github.com/mozilla/firefox-ios/pull/958/files

Couple of things:

1. Safer target/action. I was able to get crashes from the selector being called on an invalid/deallocated target. I've made the add/removal safer by binding them to the willAppear/didDisappear events.

2. Added checks to make sure we only call endRefreshing if we are refreshing.

3. Renamed the refresh method and target selector. Looking at https://crash-stats.mozilla.com/report/index/a04d4cb7-038e-435a-a203-ee0752150819#allthreads it seems that the crash is happening inside UIKit and might be a naming collision with 'refresh' considering it's a popular name for a method. Added just in case.

I haven't been able to reproduce the crash with these fixes
Attachment #8650087 - Flags: review?(rnewman)
Attachment #8650087 - Flags: review?(rnewman) → review+
Status: NEW → ASSIGNED
tracking-fxios: 1.1+ → +
Keywords: crash
Hardware: Other → All
(Assignee)

Comment 6

3 years ago
Merged
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.