Add-ons manager should check for the presence of install.rdf first when deciding what kind of add-on it is loading

RESOLVED FIXED in Firefox 42

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mossop, Assigned: rhelmer)

Tracking

Trunk
mozilla43
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox42+ fixed, firefox43 fixed)

Details

Attachments

(1 attachment)

Since add-ons may have manifest.json already present when they want to be regular add-ons we should check for the presence of install.rdf first.

Rob, do you want to take this?
[Tracking Requested - why for this release]:

This might be breaking some extensions or at least making extension developer's lives harder in 42.
Status: NEW → ASSIGNED
Attachment #8650080 - Flags: review?(dtownsend)
Attachment #8650080 - Flags: review?(dtownsend) → review+
I can confirm that this patch prevents the problem in bug 1195353
(In reply to 4mr.minj from comment #3)
> I can confirm that this patch prevents the problem in bug 1195353

Thanks for testing!
Keywords: checkin-needed
rhelmer: you broke MozReview. How did you add the patch in comment #2 to MozReview?
Flags: needinfo?(rhelmer)
(In reply to Gregory Szorc [:gps] from comment #5)
> rhelmer: you broke MozReview. How did you add the patch in comment #2 to
> MozReview?

The patch was uploaded via the web UI (https://reviewboard.mozilla.org/r/new/)
Flags: needinfo?(rhelmer)
(In reply to Robert Helmer [:rhelmer] from comment #6)
> (In reply to Gregory Szorc [:gps] from comment #5)
> > rhelmer: you broke MozReview. How did you add the patch in comment #2 to
> > MozReview?
> 
> The patch was uploaded via the web UI
> (https://reviewboard.mozilla.org/r/new/)

Spoke with gps in IRC, this is the reason the integration didn't work ^ I've got the hg plugin set up now and will just use that in the future.

The patch is ready for checkin.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Reopening until this is landed on m-c.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/08d74cb1c447
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Is this going to be backported to FF42?
(In reply to 4mr.minj from comment #11)
> Is this going to be backported to FF42?

Yes, just waiting on some testing on trunk before making the request.
Tracking to make sure we have it in 42.
Blocks: 1190692
Comment on attachment 8650080 [details]
prefer install.rdf over manifest.json

Approval Request Comment
[Feature/regressing bug #]: Bug 1190692
[User impact if declined]: Some add-ons may appear to be corrupt
[Describe test coverage new/current, TreeHerder]: On mozilla-central for a week, good automated tests
[Risks and why]: Very low risk a simple code change with good tests
[String/UUID change made/needed]: None
Attachment #8650080 - Flags: approval-mozilla-aurora?
Attachment #8650080 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.