Last Comment Bug 11965 - [FEATURE] libmime needs a way to detect the charset of the destination webshell (if available)
: [FEATURE] libmime needs a way to detect the charset of the destination webshe...
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86 Windows NT
: P3 normal (vote)
: M11
Assigned To: Warren Harris
: Paul MacQuiddy
: Patrick McManus [:mcmanus]
Mentors:
Depends on:
Blocks: 5938 12839
  Show dependency treegraph
 
Reported: 1999-08-16 12:40 PDT by rhp (gone)
Modified: 1999-12-13 16:36 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description rhp (gone) 1999-08-16 12:40:13 PDT
After a newsgroup discussion, warren posted:

 > I'm not sure how you should get the webshell from libmime. This
 > is probably related to the infamous "event sink getter" architecture
 > that is yet to be determined. I want to do that next (for m10).

So I want to make sure we track this as we move towards beta.
Comment 1 Paul MacQuiddy 1999-08-16 17:03:59 PDT
I marked this M10 per the comments above and to get off the 'Necko, no
milestone' radar. Feel free to change.
Comment 2 Warren Harris 1999-08-23 15:15:59 PDT
Gagan, should this be an accessor on nsIChannel? Or should it be an event sink?
Comment 3 Gagan 1999-08-23 17:00:59 PDT
Rick said that he was going to add it nsIHTTPChannel. It doesn't make sense to
do it to nsIChannel. But for the moment if you need to parse out the charset,
you can see anything after the semicolon on a
nsIHTTPChannel::GetResponseHeader("Content-Type", &foo); which is the raw HTTP
header as compared to the nsI[HTTP]Channel::GetContentType() call. Cc'ing
rpotts.
Comment 4 leger 1999-09-24 16:10:59 PDT
Spoke with warren at bug triage today.  Not an M10 blocker...moving to M11.
Comment 5 Warren Harris 1999-09-29 20:51:59 PDT
Looks like this has already been done. nsIHTTPChannel::GetCharset
Comment 6 Paul MacQuiddy 1999-09-30 19:29:59 PDT
I trust warren, marking verified for tracking purposes.
Comment 7 leger 1999-12-13 16:36:59 PST
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Note You need to log in before you can comment on or make changes to this bug.