Closed Bug 1196501 Opened 7 years ago Closed 7 years ago

APZ performance regression when using Home/End keys on a long page

Categories

(Core :: Panning and Zooming, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox43 --- affected

People

(Reporter: BenWa, Unassigned)

References

Details

STR:
1) Open http://planet.mozilla.org/, let it load
2) Press Home/End to scroll to the start/bottom of the page

Without APZ it's considerably smoother, but still far from perfect.

I'm not sure if we want to block APZ on this.
(In reply to Benoit Girard (:BenWa) from comment #0)
> I'm not sure if we want to block APZ on this.

I'm leaning towards no, since routing keyboard input through APZ (the correct long-term solution) is nontrivial. If we really want to do a shorter-term fix we can make the home/end trigger smooth scrolling in APZ which should make it smooth. (I'm not entirely sure what it does now, but I assume it uses the layout's "AsyncScroll" code path which isn't really so async).
Maybe bug 1198966 could help here, but I'm not sure.
Name 	Firefox
Version 	47.0a1
Build ID 	20160201030241
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.