My private extension doesn't work

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150807094952

Steps to reproduce:

Nothing. I assume firefox upgraded itself to 40.0.


Actual results:

My extension silently stopped working: https://github.com/akkartik/spew. It isn't on the addons site because it was rejected from the review process last year, and I couldn't be **** to follow up. I don't care about other people using it, I just want to modify MY own private firefox experience, for MY self.


Expected results:

My extension should have continued working.

I'd read about Firefox 42 changing some policies regarding unsigned extensions, without an about:config option to undo said policies. I'd mentally prepared myself for some upheaval over the coming months. But I'm not on firefox 42. I'm on 40.0. How can I get my extension working temporarily while I figure out whether to switch to the Nightlies (or to Chrome)?

Attempts to add the .xpi manually silently do nothing. With no errors or reasons given why the extension doesn't work, I have no idea how much effort I have to expend debugging this.

Updated

3 years ago
Component: Untriaged → Extension Compatibility

Comment 1

3 years ago
could you attach directly the .xpi file to the bug report, it'll be more easy to test.
Flags: needinfo?(mozilla)
(Reporter)

Comment 2

3 years ago
Created attachment 8650235 [details]
spew.xpi - the extension failing to run

Here you are.

(Sorry about my harsh tone above :/ I've run into several issues in Firefox 40, and in my frustration I was making assumptions about what was causing them. I'll open more bugs for the other issues. Thanks for not rising to the bait. I look forward to hearing with what accidental jetpack abuse I brought this on myself.)
Flags: needinfo?(mozilla)
It looks like you're using the 'widget' module, which was dropped in Firefox 40. See this post for more information: https://blog.mozilla.org/addons/2015/06/18/compatibility-for-firefox-40/

I don't think there's anything else we can do on the Firefox side.

As for signing, the main doc for it is here: https://wiki.mozilla.org/Addons/Extension_Signing
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

3 years ago
Thanks, it works after I disabled that bit of functionality.
You need to log in before you can comment on or make changes to this bug.