bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Support NNTP AUTHINFO authentication

NEW
Unassigned

Status

MailNews Core
Networking: NNTP
--
enhancement
17 years ago
4 years ago

People

(Reporter: Marc Prud'hommeaux, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Microsoft servers require that the user use SPA (Secure Password Authentication)
to log into their NNTP servers. This means that no-one that uses MSN's News
Servers can use Mozilla as their Newsgroup reader. This will get more and more
important as MSN becomes a larger ISP.

Some code from the Samba project can be used to provide SPA support. I have
successfully plugged this code into the recent version of the news reader Pan
(also, fetchmail has used this code to provide POP access the MS servers).
You can see a trimmed down module for SPA support at:
http://www.storrow.org/Software/SPA_Authentication/

If there is enough interest, I could try to add in support to Mozilla myself.

PS. I haven't tried, but I bet this problem also applies to not being able
to log into an MS POP server.
Confirming, setting to request for enhancement, since this isn't in any specs
currently.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

16 years ago
I don't know if this is exactly the same issue, but my old Netscape 4.7 would 
allow me to "always ask me for my user name and password", because it was needed 
to authenticate to the secure news reader.

This option is not available in 1.0RC2.  So I cannot log onto the news server.

Can you confirm whether this is the same issue or not?

Thank you.

Comment 3

16 years ago
I can confirm this doesn't work (SPA) login. My wife goes to U of Phoenix online
and I can't connect to their servers, SPA is checked in M$-OutLook.
I get asked username/password and enter it correctly but that doesn't get me
into the news server.  This is ALL that is stopping me from being M$ free !!!

Thanks.

Comment 4

16 years ago
I think this is definately needed for many individuals stuck trying to connect
to Microsoft Servers.  In my situation I need to be able to authenticate using
SPA for both IMAP and NNTP.

Comment 5

16 years ago
I'm locked into MSN since it is part of the DSL service provided by Qwest.  A
few months ago (summer, 2002) I was notified by MSN that I was required to use
SPA to access the POP3 mail servers.  They provided examples on how to configure
Outlook and Outlook Express, which I have been using.  Would prefer to use
Mozilla, but without SPA support, I cannot retrieve my mail.
(Reporter)

Comment 6

16 years ago
Some good information on this protocol can be found at:

http://www.kuro5hin.org/story/2002/4/28/1436/66154

Comment 7

15 years ago
Compuserve Pop server also uses SPA.  I am unable to use Mozilla mail to
retrieve my compuserve mail.  My Outlook Express setting for my compuserve
account has the 'Secure Password Authentication' box checked.

Comment 8

15 years ago

*** This bug has been marked as a duplicate of 200436 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 9

15 years ago
sorry for the spam, bug 200436 covers NTLM over SMTP & POP, not NNTP.
Status: RESOLVED → REOPENED
Depends on: 200436
Resolution: DUPLICATE → ---

Comment 10

15 years ago
Can someone give me an address to a freely accessible (not bound to a dialin
provider) newsserver that supports SPA? I don't know how SPA is incorporated
into NNTP, so I can't help at the mometn.

Comment 11

15 years ago
updated URL from initial report: http://www.storrow.org/code.php

You may want to check Pan code for an implementation example, it may help what a
NNTP server is expecting:
http://cvs.gnome.org/bonsai/cvsblame.cgi?file=pan%2Fpan/nntp.c&rev=&root=/cvs/gnome

Comment 12

15 years ago
Thanks Olivier. That looks quite similar to SMTP and POP3, and should therefore
be implemented in a relatively short time.
But even if implementing can be done from spec and examples, testing requires a
testserver. Any idea?

Comment 13

15 years ago
Christian, unfortunately, no, I've been browsing free NNTP sites without finding
one that require SPA, there used be netnews.msn.com but it doesn't exist anymore
afaik.
http://dmoz.org/Computers/Usenet/Public_News_Servers/
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Status: REOPENED → NEW
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
Looking at one the URIs provided indicates that this is merely supporting AUTHINFO and SASL in NNTP. CC'ing some people with SASL experience.
Summary: Cannot log in to NNTP servers that require Secure Password Authentication → Support NNTP AUTHINFO authentication
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.