[pp]instantiated tooltip disables popupmenu

VERIFIED FIXED in M10

Status

()

Core
XUL
P2
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: phillip, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview Description:
	after a tooltip for a button is created and displayed, clicking on
	the titledbutton does not make the tooltip vanish.
	(note: this is different from bug 11973)

Steps to Reproduce:
	1) start apprunner on winnt (or hopefully some other win32 flavor)
	2) mouseover the Mozilla titledbutton of the bottom tasks overlay
	3) wait for the tooltip to appear.
	4) now click the Mozilla button once. notice what happens.

Actual Results:

	When you click on the Mozilla button, the popmenu does
	appear, but the tooltip does not vanish like it's supposed to.

Expected Results:

	The first time you click the Mozilla button, the tooltip should vanish
	and the menu should popup.

Occurs on:
     1999-08-16-09 WinNT 4.0 sp5

A different bug occurs on:
     1999-08-16-08 MacOS 8.51 (bug 11973)

Does not occur on: (not yet implemented)
     1999-08-16-09 RedHat Linux 6.0 (GNOME/enlightenment)

Updated

19 years ago
Assignee: trudelle → saari
Priority: P3 → P2
Target Milestone: M10

Comment 1

19 years ago
reproduced using today's opt bits on win98. Worse, trying it 2-3 times caused a
crash for me.  reassigning to saari as p2 for m10

Comment 2

19 years ago
Pink, I'm venturing a guess that this is yours, or maybe hyatt's with dismissing
popups
Assignee: saari → pinkerton
Assignee: pinkerton → hyatt
i think it's a dismissing popups problem. redirecting to hyatt.

Updated

19 years ago
Blocks: 12670

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
resolved as fixed
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
ummm... i think tooltips and popups and whatnot were reimplemented,
so any new misbehavior is caused by something else. i'll just verify.
You need to log in before you can comment on or make changes to this bug.