[e10s] Firefox occasionally hangs when switching tabs that contain plugin content

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Trevor Rowbotham, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(e10s-, firefox43 affected)

Details

(Reporter)

Description

3 years ago
I *think* this only occurs when you switch away from a tab that contains a plugin and not when you switch to a tab that contains a plugin, but I could be wrong about this.  I noted in Bug 1163570, comment 17, I was seeing this behavior where Firefox would become unresponsive with the test build from Bug 1163570, comment 15, so I am tentatively marking this as blocking Bug 1163570.

STR:
1) Open 2 tabs.
2) In the second tab, open a page that contains a plugin.
3) If necessary, activate the plugin using click-to-play.
4) Switch between the tabs

Actual Results
The browser will sometimes hang forcing you to end the task.  Upon restarting the browser, it will prompt you to restore your session.  Below are some of the crash reports that I received when this happened.

bp-3dc13ffe-b866-4036-9e13-6a6002150822
bp-2f98766d-2096-442c-86cc-c9f8c2150822
bp-3b9bf4e7-c94e-4a4b-a48c-971932150822

Expected Results:
The browser should not hang.

Updated

3 years ago
Blocks: 1137944
No longer blocks: 1163570

Updated

3 years ago
tracking-e10s: --- → -
(Reporter)

Comment 1

3 years ago
I worded my original post poorly.  I experienced this behavior for the first time in the build from Bug 1163570, comment 15,  but now I am experiencing this behavior in the latest nightly build, which is why I filed this against Bug 1163570.  Also, probably helpful to know that this happened on Windows 10.

Jim, I'll let you decide if this should go back to blocking Bug 1163570 or not, since I'm not 100% certain that Bug 1163570 is the culprit here. Just correlating events led me to believe that Bug 1163570 was the culprit.
Flags: needinfo?(jmathies)

Comment 2

3 years ago
Seriously doubt is was bug 1163570, that just changed some logic about plugin update processing.

When do the hangs usually happen? Your stacks don't show much unfortunately. The browser indicates the crash report is taken on a shutdown hang.
No longer blocks: 1137944
Flags: needinfo?(jmathies)
(Reporter)

Comment 3

3 years ago
Yeah, the crash reports are likely being generated when I kill the browser once it hangs.  As you pointed out, the stacks don't really show much, which is why I was just guessing that it was related to Bug 1163570, since that test build was the only other time I had seen this happen before.

From what I can tell, the hang occurs either when closing a tab or switching between tabs. I'll have to investigate this more as I am having trouble reproducing this with a clean profile, but can fairly easily get it to occur in my regular profile.  Whenever I try to reproduce with a clean profile I run into Bug 1196539, but my regular profile doesn't seem to be affected by that bug, so I'm not sure if that is the difference between me not being able to reproduce this with a clean profile vs my regular profile.
(Reporter)

Comment 4

2 years ago
This was fixed by Bug 1197943.  Closing.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.