Closed Bug 1197601 Opened 7 years ago Closed 5 years ago

Smooth scrolling (APZ) is janky compared to auto scrolling on this site

Categories

(Web Compatibility :: Desktop, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: nissan4321, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150822030206

Steps to reproduce:

1) Enter: http://cheatspirates.com/swordsman-hack-free-gold-and-sycee-cheats/
2) Start scrolling using the mouse wheel (APZ) - janky :(
3) Start auto scrolling the page using the middle mouse button - not janky.


Actual results:

Smooth scrolling via APZ is janky compared to auto scrolling.


Expected results:

Smooth scrolling via APZ should be on par with auto scrolling - jank free.
Blocks: apz-desktop
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
They are intercepting the wheel events and doing their own scrolling. The physics of it is different too (on OS X at least).
Status: UNCONFIRMED → NEW
Component: Panning and Zooming → Desktop
Ever confirmed: true
Product: Core → Tech Evangelism
(Actually this may just be INVALID since the behaviour with APZ should be pretty much the same as the behaviour without APZ)
Whiteboard: [needsdiagnosis]
I am closing this as INVALID. The site uses a jQuery plugin called "fancyScroll" on the HTML node:

jQuery(document).ready(function(){
  jQuery("html").niceScroll({
    cursorcolor:"#4d4d4d",
    cursorborder:"0px",
    cursorwidth:"7px",
  });
});

The plugin intercepts scroll events and blocks them to make scrolling look... more fancy by transitioning the top-attribute of a nested container. The plugin also adds a little bit of delay and some inertia simulations. The scrolling behavior on this site is intentional and feels the same in all browsers.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Whiteboard: [needsdiagnosis]
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.