Long tooltips are placed wrong and cropped in a wrong way - corners on the right should be rounded

RESOLVED DUPLICATE of bug 863824

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 863824
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8651515 [details]
Long tooltip is placed wrong and cropped in a wrong way - corners on the right should be rounded.png

STR:   (Win7, Nightly 43.0a1 (2015-08-20))
1. Open the following "data:" URL in a new tab:
   data:text/html,<script>var S=''; for (i=0;i<999;i++) S+='t'; document.title=S+' 2nd_line';</script>
2. Hover mouse over that tab to see the tooltip with title

Result:       Tooltip is cropped (that's ok), bug corners on the right are not rounded
Expectations: Top-right and bottom-right corners of tooltip should be rounded

Note that this bug is different from bug 233371, and this shouldn't be marked as duplicate of that bug, because if 233371 will be marked as WONTFIX, this bug would still be actual.
(Reporter)

Updated

2 years ago
Component: Widget: Gtk → Widget: Win32
(Reporter)

Comment 1

2 years ago
Note:
This bug isn't only about rounded corners, but also about tooltip placement and visible text in tooltip

So, add this to expectations:
 2) Tooltip should be aligned near the element with <title> attribute which triggered the tooltip
 3) Long strings should be broken into a smaller ones, so that all text in tooltip was visible
No longer depends on: 233371
See Also: → bug 357337
Whiteboard: [dupeme]
(Reporter)

Updated

2 years ago
Has STR: --- → yes

Updated

2 years ago
See Also: → bug 949917
(Reporter)

Comment 2

2 years ago
Yeah, this is definitely a duplicate of bug 863824, just like 949917. Thanks!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [dupeme]
Duplicate of bug: 863824
You need to log in before you can comment on or make changes to this bug.