Nightly freezes with KWin + EGL + SNA

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: johnp, Unassigned)

Tracking

(Blocks 1 bug, {crash, hang})

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Whiteboard: gfx-noted, crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-3fdaedae-0cb3-4b11-ab9c-e1d222150823.
=============================================================

Latest Firefox nightly freezes reliably after some minutes of usage. No STR yet.

Crashed it with SIGABRT three times, all reports identical:

bp-43880f33-e2b5-4508-9a5e-758f02150823
bp-2842a1b8-eb91-46c8-885f-72d8c2150823
bp-3fdaedae-0cb3-4b11-ab9c-e1d222150823
(Reporter)

Comment 1

4 years ago
Seems to work again after a full system restart + kernel update to 4.1.6.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
Not...
Safe-Mode didn't freeze yet, so investigating if it's Add-On related.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

4 years ago
Ok, this is only reproducible when enabling EGL for KWin.
Related to KDE bug 347507:

https://bugs.kde.org/show_bug.cgi?id=347507
Component: General → Graphics
Product: Firefox → Core
(Reporter)

Updated

4 years ago
Summary: Frequent freezes in nightly → Nightly freezes with KWin + EGL
Whiteboard: gfx-noted
From the crash reports, it's crashing at the PollWrapper[1], which was added by bug 429592.

[1] https://dxr.mozilla.org/mozilla-central/source/widget/gtk/nsAppShell.cpp?offset=100#42
(Reporter)

Comment 5

4 years ago
Fwiw (without knowing any of the involved components), it looks to me like Firefox is still running as intended (aka not hanging, also indicated by fluctuating CPU/RAM-usage), but somehow Firefox and KDEs taskbar trigger EGL code that results in some areas not getting repainted anymore (does that make any sense?). On KDEs taskbar for example, highlights for hovered windows still work, but the highlight for the active window is stuck.
Another bit of info: With another session I was able to reproduce the freeze nearly instantly, so maybe one of the websites triggers the issue. Please also cross-read the KDE bug, as I may mix some things up unintended.
(Reporter)

Comment 6

4 years ago
Cross-Post: KWin + EGL + Intel SNA are needed to trigger the issue.
(Note: SNA is default, EGL not)

Using multiple windows, I'm able to get the window with the mentioned session to freeze, while the window where I'm writing this comment is fully functional. I'll try to reduce the session tomorrow.
Summary: Nightly freezes with KWin + EGL → Nightly freezes with KWin + EGL + SNA
(Reporter)

Comment 7

4 years ago
The bug-report has been closed upstream, because apparently Intel SNA has issues with GLX clients in an EGL compositor.

Should this bug remain open and depend on bug 788319 for tracking purposes / easiness to find or should it be closed instead?
Status: REOPENED → NEW
(In reply to Johannes Pfrang [:johnp] from comment #7)
> The bug-report has been closed upstream, because apparently Intel SNA has
> issues with GLX clients in an EGL compositor.
> 
> Should this bug remain open and depend on bug 788319 for tracking purposes /
> easiness to find or should it be closed instead?
Flags: needinfo?(anthony.s.hughes)
Keywords: crash
I'm not sure what we should do here. If it's been resolved upstream then perhaps there's nothing to be done on our end and this can be closed. Anecdotally, the crash signature has only had 1 report over the last week and 43 reports over the last 6 months (all but one are on unsupported Firefox versions).

I would say that this should certainly be added to the dependency tree for bug 788319 just for tracking purposes. However, I'll leave it up to Milan to decide if this bug should remain open.
Blocks: 788319
Flags: needinfo?(anthony.s.hughes) → needinfo?(milan)
(Reporter)

Comment 10

4 years ago
Not exactly resolved, but it looks like you can work around a lot of EGL issues (including this one) by also enabling DRI3. Going to test these settings (SNA+EGL+DRI3) and report back. Maybe we can get a good workaround for people running into this.
Flags: needinfo?(milan)
(Reporter)

Comment 11

4 years ago
Looks good! No freezes here. Example xorg.conf or xorg.conf.d/20-intel.conf:

> Section "Device"
>  Identifier "Intel Graphics"
>  Driver "intel"
>  Option "AccelMethod" "sna"
>  Option "DRI" "3"
> EndSection
Thanks for checking.
Status: NEW → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.