mozInputMethod.addInput() shouldn't call _sendPromise() anymore

RESOLVED FIXED in Firefox 43, Firefox OS master

Status

()

Core
DOM
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: timdream, Assigned: timdream)

Tracking

({regression})

unspecified
mozilla43
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox43 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

The patch in bug 904479 missed this one _sendPromise() call and only changed the one in removeInput().

https://hg.mozilla.org/mozilla-central/file/0f5421c28b14/dom/inputmethod/MozKeyboard.js#l384

Unfortunately both methods were not covered by tests because their end result is to cause mozChromeEvents to System app -- which is untestable in any of our test suites. I can't test the entire flow with Gij tests either because the flow (download the dictionary and enable it) involves external file download.

Let me submit a one-liner here and work on replacing these mozChromeEvents with events later.
blocking-b2g: --- → 2.5+
status-firefox43: --- → affected
Created attachment 8651601 [details] [diff] [review]
Patch
Attachment #8651601 - Flags: review?(kchen)
Attachment #8651601 - Flags: review?(kchen) → review+
Keywords: checkin-needed
Keywords: regression
https://hg.mozilla.org/mozilla-central/rev/dd9b9887e889
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox43: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
status-b2g-master: --- → fixed
You need to log in before you can comment on or make changes to this bug.