Intermittent test_bug864040.html | TEXTAREA: caret is not on new line | DIV: caret is not on new line

RESOLVED FIXED in Firefox 45

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: jfkthame)

Tracking

({intermittent-failure})

Trunk
mozilla46
Unspecified
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox43 affected, firefox45 fixed, firefox46 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 8
* fx-team: 3
* b2g-inbound: 3
* mozilla-central: 1

Platform breakdown:
* linux64: 15

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-11-05&endday=2015-11-05&tree=all
16 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 10
* mozilla-central: 2
* fx-team: 2
* try: 1
* b2g-inbound: 1

Platform breakdown:
* linux64: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-11-06&endday=2015-11-06&tree=all
51 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 31
* fx-team: 7
* mozilla-central: 6
* b2g-inbound: 5
* try: 2

Platform breakdown:
* linux64: 51

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-11-02&endday=2015-11-08&tree=all
Depends on: 1223198
57 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 25
* b2g-inbound: 12
* fx-team: 10
* mozilla-central: 8
* try: 2

Platform breakdown:
* linux64: 57

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-11-09&endday=2015-11-15&tree=all
53 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 21
* fx-team: 19
* mozilla-central: 6
* b2g-inbound: 6
* try: 1

Platform breakdown:
* linux64: 53

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-11-16&endday=2015-11-22&tree=all
18 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 7
* fx-team: 4
* b2g-inbound: 4
* mozilla-central: 3

Platform breakdown:
* linux64: 18

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-11-24&endday=2015-11-24&tree=all
69 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 39
* fx-team: 14
* mozilla-central: 9
* b2g-inbound: 4
* try: 3

Platform breakdown:
* linux64: 69

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-11-23&endday=2015-11-29&tree=all
55 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 30
* fx-team: 13
* mozilla-central: 8
* try: 3
* b2g-inbound: 1

Platform breakdown:
* linux64: 55

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-11-30&endday=2015-12-06&tree=all
24 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 19
* fx-team: 3
* try: 2

Platform breakdown:
* linux64: 24

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-12-11&endday=2015-12-11&tree=all
56 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 40
* fx-team: 8
* try: 4
* mozilla-central: 3
* b2g-inbound: 1

Platform breakdown:
* linux64: 56

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-12-07&endday=2015-12-13&tree=all
20 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 10
* fx-team: 4
* b2g-inbound: 3
* mozilla-central: 2
* mozilla-aurora: 1

Platform breakdown:
* linux64: 20

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-12-16&endday=2015-12-16&tree=all
63 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 43
* fx-team: 8
* b2g-inbound: 5
* mozilla-central: 4
* mozilla-aurora: 2
* try: 1

Platform breakdown:
* linux64: 63

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-12-14&endday=2015-12-20&tree=all
Looks like this is rather common failure.
Yes. But if this is becoming very frequent and annoying, we should probably workaround it via suppressing the native widget painting in this test, like what :dholbert is going to do in bug 1204897. It doesn't seem bug 1223198 gets much progress.
61 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 27
* fx-team: 13
* try: 6
* mozilla-central: 5
* mozilla-aurora: 5
* b2g-inbound: 5

Platform breakdown:
* linux64: 61

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-12-21&endday=2015-12-27&tree=all
30 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 17
* mozilla-central: 4
* mozilla-aurora: 3
* b2g-inbound: 3
* try: 2
* fx-team: 1

Platform breakdown:
* linux64: 30

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2015-12-28&endday=2016-01-03&tree=all
17 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 11
* mozilla-aurora: 3
* fx-team: 2
* b2g-inbound: 1

Platform breakdown:
* linux64: 17

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2016-01-05&endday=2016-01-05&tree=all
18 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 11
* mozilla-aurora: 2
* fx-team: 2
* try: 1
* mozilla-central: 1
* b2g-inbound: 1

Platform breakdown:
* linux64: 18

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2016-01-06&endday=2016-01-06&tree=all
Jim, can you take a look at this (admittedly low failure rate) orange test?
Flags: needinfo?(nchen)
76 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 37
* fx-team: 14
* mozilla-aurora: 9
* try: 7
* mozilla-central: 5
* b2g-inbound: 4

Platform breakdown:
* linux64: 76

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2016-01-04&endday=2016-01-10&tree=all
I compared the screenshots and the failure is caused by subtle differences in how the text field is rendered, so seems like bug 1223198 is the way to fix this failure.
Flags: needinfo?(nchen)
(Assignee)

Comment 24

3 years ago
Created attachment 8707569 [details] [diff] [review]
Use -moz-appearance:none on textarea in test_bug864040.html to work around unreliable Gtk3-themed rendering

Same old thing; as the test here is about the contents, not the native-themed rendering of the textarea, we can again -moz-appearance our way to victory.
Attachment #8707569 - Flags: review?(dholbert)
(Assignee)

Updated

3 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
Attachment #8707569 - Flags: review?(dholbert) → review+
(Assignee)

Comment 25

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f92eed8116df975ea167168a724c8d3cd103bea5
Bug 1197786 - Use -moz-appearance:none on textarea in test_bug864040.html to work around unreliable Gtk3-themed rendering. r=dholbert

Comment 26

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f92eed8116df
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
27 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 19
* fx-team: 4
* mozilla-aurora: 2
* mozilla-central: 1
* b2g-inbound: 1

Platform breakdown:
* linux64: 27

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1197786&startday=2016-01-11&endday=2016-01-17&tree=all

Comment 28

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/d7449bca2b22
status-firefox45: --- → fixed
You need to log in before you can comment on or make changes to this bug.