Closed Bug 1197979 Opened 4 years ago Closed 4 years ago

Tools > Logins menu item is not visible

Categories

(Firefox for Android :: Logins, Passwords and Form Fill, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
firefox42 --- fixed
firefox43 --- verified
fennec 42+ ---

People

(Reporter: mfinkle, Assigned: ally)

References

Details

Attachments

(1 file, 1 obsolete file)

We manually controlled the menu visibility in code, using the AppConstants.NIGHTLY_BUILD flag. We left this code in place when we removed the nightly flag, but we re-used a | visible | variable that didn't do what we thought. In fact, we should have just used | true | since we always want the menu item visible.

That said, the better approach was to remove the code from BrowserApp and just let the menu be visible by default, which is what the menu XML will do
tracking-fennec: --- → ?
Attached patch loginsMissingToolsMenuItem (obsolete) — Splinter Review
Since you loathe rb..
Attachment #8652557 - Flags: review?(mark.finkle)
Comment on attachment 8652557 [details] [diff] [review]
loginsMissingToolsMenuItem

Can you try just removing the line of code? The menu should be visible by default since we don't explicitly set visible to false anywhere.
Attachment #8652557 - Flags: review?(mark.finkle) → review-
tracking-fennec: ? → 42+
Attachment #8652557 - Attachment is obsolete: true
Attachment #8653610 - Flags: review?(mark.finkle)
Attachment #8653610 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/8236022b63e6
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Reproduced the issue on 22-08 build, verified as fixed using Nexus 4 (Android 5.1) on latest Nightly (2015-08-31).
Status: RESOLVED → VERIFIED
Ally - Let's get an uplift to Fx42 in motion
Flags: needinfo?(ally)
Comment on attachment 8653610 [details]
loginsMissingToolsMenuItem

Approval Request Comment
[Feature/regressing bug #]: about:logins, login manager on mobile
[User impact if declined]: users will have difficulty getting to the login manager
[Describe test coverage new/current, TreeHerder]: robocop tests
[Risks and why]: minimal, menu item show/hide
[String/UUID change made/needed]: none
Flags: needinfo?(ally)
Attachment #8653610 - Flags: approval-mozilla-aurora?
Comment on attachment 8653610 [details]
loginsMissingToolsMenuItem

Approved for uplift to aurora. Login menu items are useful!
Attachment #8653610 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.