Closed Bug 1198237 Opened 6 years ago Closed 6 years ago

Can't build b2g debug gecko on Mac any more: undefined reference to 'unum_close_55'

Categories

(Core :: JavaScript: Internationalization API, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed

People

(Reporter: gwagner, Assigned: freesamael)

References

Details

Attachments

(1 file)

INPUT("../../modules/zlib/src/uncompr.o")
    INPUT("../../modules/zlib/src/zutil.o")
    INPUT("StaticXULComponentsEnd/StaticXULComponentsEnd.o")

/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: error: ../../intl/icu/target/lib/libicui18n.a: no archive symbol table (run ranlib)
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: error: ../../intl/icu/target/lib/libicuuc.a: no archive symbol table (run ranlib)
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: error: ../../intl/icu/target/lib/libicudata.a: no archive symbol table (run ranlib)
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: warning: hidden symbol 'vorbis_info_init' in /Users/gregor/moz/ib2g/debaries/toolkit/library/../../media/libtremor/lib/tremor_info.o is referenced by DSO /Volumes/disc2/aries/B2G/out/target/product/aries/obj/lib/libstagefright.so
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: warning: hidden symbol 'vorbis_comment_init' in /Users/gregor/moz/ib2g/debaries/toolkit/library/../../media/libtremor/lib/tremor_info.o is referenced by DSO /Volumes/disc2/aries/B2G/out/target/product/aries/obj/lib/libstagefright.so
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: warning: hidden symbol 'vorbis_comment_clear' in /Users/gregor/moz/ib2g/debaries/toolkit/library/../../media/libtremor/lib/tremor_info.o is referenced by DSO /Volumes/disc2/aries/B2G/out/target/product/aries/obj/lib/libstagefright.so
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: warning: hidden symbol 'vorbis_info_clear' in /Users/gregor/moz/ib2g/debaries/toolkit/library/../../media/libtremor/lib/tremor_info.o is referenced by DSO /Volumes/disc2/aries/B2G/out/target/product/aries/obj/lib/libstagefright.so
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: warning: hidden symbol 'oggpack_readinit' in /Users/gregor/moz/ib2g/debaries/toolkit/library/../../media/libogg/Unified_c_media_libogg0.o is referenced by DSO /Volumes/disc2/aries/B2G/out/target/product/aries/obj/lib/libstagefright.so
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: warning: hidden symbol 'oggpack_read' in /Users/gregor/moz/ib2g/debaries/toolkit/library/../../media/libogg/Unified_c_media_libogg0.o is referenced by DSO /Volumes/disc2/aries/B2G/out/target/product/aries/obj/lib/libstagefright.so
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: error: ../../js/src/libjs_static.a(Unified_cpp_js_src0.o): requires unsupported dynamic reloc R_ARM_REL32; recompile with -fPIC
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: error: ../../js/src/libjs_static.a(Unified_cpp_js_src0.o): requires unsupported dynamic reloc R_ARM_REL32; recompile with -fPIC
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: error: ../../js/src/libjs_static.a(Unified_cpp_js_src0.o): requires unsupported dynamic reloc R_ARM_REL32; recompile with -fPIC
/Volumes/disc2/aries/B2G/prebuilts/gcc/darwin-x86/arm/arm-linux-androideabi-4.7/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: error: read-only segment has dynamic relocations
/Users/gregor/moz/ib2g/intl/unicharutil/util/ICUUtils.h:26: error: undefined reference to 'unum_close_55'
/Users/gregor/moz/ib2g/intl/unicharutil/util/ICUUtils.cpp:147: error: undefined reference to 'unum_open_55'
/Users/gregor/moz/ib2g/intl/unicharutil/util/ICUUtils.cpp:153: error: undefined reference to 'unum_parseDouble_55'
/Users/gregor/moz/ib2g/intl/unicharutil/util/ICUUtils.cpp:108: error: undefined reference to 'unum_open_55'
/Users/gregor/moz/ib2g/intl/unicharutil/util/ICUUtils.cpp:110: error: undefined reference to 'unum_setAttribute_55'
/Users/gregor/moz/ib2g/intl/unicharutil/util/ICUUtils.cpp:114: error: undefined reference to 'unum_setAttribute_55'
/Users/gregor/moz/ib2g/intl/unicharutil/util/ICUUtils.cpp:116: error: undefined reference to 'unum_formatDouble_55'
/Users/gregor/moz/ib2g/gfx/thebes/gfxHarfBuzzShaper.cpp:1206: error: undefined reference to 'unorm2_getRawDecomposition_55'
/Users/gregor/moz/ib2g/gfx/thebes/gfxHarfBuzzShaper.cpp:1215: error: undefined reference to 'utext_next32_55'
/Users/gregor/moz/ib2g/gfx/thebes/gfxHarfBuzzShaper.cpp:1219: error: undefined reference to 'utext_next32_55'
/Users/gregor/moz/ib2g/gfx/thebes/gfxHarfBuzzShaper.cpp:1223: error: undefined reference to 'utext_close_55'
/Users/gregor/moz/ib2g/gfx/thebes/gfxHarfBuzzShaper.cpp:1212: error: undefined reference to 'utext_openUChars_55'
/Users/gregor/moz/ib2g/gfx/thebes/gfxHarfBuzzShaper.cpp:1076: error: undefined reference to 'unorm2_composePair_55'
/Users/gregor/moz/ib2g/gfx/thebes/gfxHarfBuzzShaper.cpp:1319: error: undefined reference to 'unorm2_getNFCInstance_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:683: error: undefined reference to 'ucol_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1179: error: undefined reference to 'unum_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1649: error: undefined reference to 'udat_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1279: error: undefined reference to 'icu_55::Locale::Locale(char const*, char const*, char const*, char const*)'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1281: error: undefined reference to 'icu_55::NumberingSystem::createInstance(icu_55::Locale const&, UErrorCode&)'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1292: error: undefined reference to 'icu_55::Locale::~Locale()'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1286: error: undefined reference to 'icu_55::NumberingSystem::getName() const'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1768: error: undefined reference to 'ucal_open_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1769: error: undefined reference to 'ucal_getType_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1774: error: undefined reference to 'ucal_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1783: error: undefined reference to 'ucal_getKeywordValuesForLocale_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1790: error: undefined reference to 'uenum_count_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1797: error: undefined reference to 'uenum_next_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:539: error: undefined reference to 'uenum_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:774: error: undefined reference to 'ucol_getKeywordValuesForLocale_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:781: error: undefined reference to 'uenum_count_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:539: error: undefined reference to 'uenum_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:793: error: undefined reference to 'uenum_next_55'
../../dist/include/js/RootingAPI.h:690: error: undefined reference to 'udat_countAvailable_55'
../../dist/include/js/RootingAPI.h:690: error: undefined reference to 'udat_getAvailable_55'
../../dist/include/js/RootingAPI.h:690: error: undefined reference to 'unum_countAvailable_55'
../../dist/include/js/RootingAPI.h:690: error: undefined reference to 'unum_getAvailable_55'
../../dist/include/js/RootingAPI.h:690: error: undefined reference to 'ucol_countAvailable_55'
../../dist/include/js/RootingAPI.h:690: error: undefined reference to 'ucol_getAvailable_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:989: error: undefined reference to 'ucol_strcoll_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1836: error: undefined reference to 'u_strlen_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1839: error: undefined reference to 'udatpg_open_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1847: error: undefined reference to 'udatpg_getBestPattern_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:539: error: undefined reference to 'udatpg_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1858: error: undefined reference to 'udatpg_getBestPattern_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1454: error: undefined reference to 'unum_formatDouble_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1459: error: undefined reference to 'unum_formatDouble_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1967: error: undefined reference to 'udat_format_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1972: error: undefined reference to 'udat_format_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1916: error: undefined reference to 'u_strlen_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1930: error: undefined reference to 'u_strlen_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1938: error: undefined reference to 'udat_open_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1946: error: undefined reference to 'udat_getCalendar_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1947: error: undefined reference to 'ucal_setGregorianChange_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1413: error: undefined reference to 'unum_open_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1421: error: undefined reference to 'unum_setTextAttribute_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:539: error: undefined reference to 'unum_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1428: error: undefined reference to 'unum_setAttribute_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1429: error: undefined reference to 'unum_setAttribute_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:943: error: undefined reference to 'ucol_open_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:949: error: undefined reference to 'ucol_setAttribute_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:950: error: undefined reference to 'ucol_setAttribute_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:951: error: undefined reference to 'ucol_setAttribute_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:952: error: undefined reference to 'ucol_setAttribute_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:956: error: undefined reference to 'ucol_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:2025: error: undefined reference to 'udat_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1512: error: undefined reference to 'unum_close_55'
/Users/gregor/moz/ib2g/js/src/builtin/Intl.cpp:1042: error: undefined reference to 'ucol_close_55'
/Users/gregor/moz/ib2g/js/src/jsapi.cpp:641: error: undefined reference to 'u_cleanup_55'
/Users/gregor/moz/ib2g/js/src/jsapi.cpp:696: error: undefined reference to 'u_setMemoryFunctions_55'
/Users/gregor/moz/ib2g/js/src/jsapi.cpp:6262: error: undefined reference to 'icu_55::TimeZone::recreateDefault()'
/Users/gregor/moz/ib2g/js/src/jsapi.cpp:599: error: undefined reference to 'u_init_55'
/Users/gregor/moz/ib2g/js/src/jsstr.cpp:941: error: undefined reference to 'unorm_normalize_55'
/Users/gregor/moz/ib2g/js/src/jsstr.cpp:951: error: undefined reference to 'unorm_normalize_55'
collect2: error: ld returned 1 exit status
make[6]: *** [libxul.so] Error 1
make[5]: *** [toolkit/library/target] Error 2
make[4]: *** [compile] Error 2
make[3]: *** [default] Error 2
make[2]: *** [realbuild] Error 2
make[1]: *** [build] Error 2
make: *** [out/target/product/aries/obj/DATA/gecko_intermediates/gecko] Error 2
Not 100% sure but probably caused by bug 1172609?
Blocks: 1172609
Flags: needinfo?(tclancy)
I did a quick bisect and it is caused by 1172609
Assignee: nobody → tclancy
Flags: needinfo?(tclancy)
Encountered the same issue. Turns out NDK's ranlib was not passed to icu, and the build script used host's ranlib instead.

Since Mac OS X uses clang toolchain and clang's ranlib is not compatible with gnu ar and ld, building fails. Adding a simple export RANLIB should resolve this issue.
Attachment #8652692 - Flags: review?(tclancy)
Attachment #8652692 - Flags: feedback?(anygregor)
Comment on attachment 8652692 [details] [diff] [review]
Pass-RANLIB-in-icu.m4. r=ted

Review of attachment 8652692 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. Thanks, Samael.
Attachment #8652692 - Flags: review+
Comment on attachment 8652692 [details] [diff] [review]
Pass-RANLIB-in-icu.m4. r=ted

Review of attachment 8652692 [details] [diff] [review]:
-----------------------------------------------------------------

Er, you're going to need a review by a module peer, so I'll forward this review to Ted Mielczarek.
Attachment #8652692 - Flags: review?(ted)
Attachment #8652692 - Flags: review?(tclancy)
Attachment #8652692 - Flags: review+
Thanks for forwarding me to the correct reviewer, Ted.
Attachment #8652692 - Flags: review?(ted) → review+
Comment on attachment 8652692 [details] [diff] [review]
Pass-RANLIB-in-icu.m4. r=ted

works now \o/
Attachment #8652692 - Flags: feedback?(anygregor) → feedback+
b-i please :)
Keywords: checkin-needed
Attachment #8652692 - Attachment description: Pass-RANLIB-in-icu.m4.patch → Pass-RANLIB-in-icu.m4. r=ted
Although only one-line change, I triggered a try, just in case:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=aeecc97c207c
Assignee: tclancy → sawang
https://hg.mozilla.org/mozilla-central/rev/fd4a578a82d4
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.