Devtools can't determine the direction of tooltip correctly IF the element is placed close to the top of the window

RESOLVED DUPLICATE of bug 932317

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 932317
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8652312 [details]
Devtools can't determine the direction of tooltip.png

STR:   (Win7_64bit, Nightly 43.0a1 (2015-08-24) 32bit)
1. Open this "data:" url in a new tab (or click URL field above):
data:text/html,<img src="chrome://branding/content/about-logo.png%23very_very_long_string_very_very_long_string_very_very_long_string_">
2. Open Devtools -> Inspector, inspect <img> element
3. Dock Inspector to the right side of window, hover mouse over the last symbols of "src" value

Result:       Tooltip's triangle is pointing down
Expectations: It should be pointing up, from the tooltip itself to the text.

My thoughts:  I believe this is happening because when you hover mouse, first there appears a small tooltip saying "192x192" (I know that from bug 1198250). There's enough place for that tooltip so it's pointing down. But then tooltip gets image data and is forced to move down, but triangle (arrow) stays on the bottom

I filed this bug because I saw the same in Debugger: when you hover mouse over a variable, tooltip displays its properties (if it's object). Again, first there appears a small tooltip saying "no data" or something (can't convert the screencast right now). If the variable is placed on top of the window, then when tooltip tooltip gets data, it's forced to move down, but arrow stays on the bottom
(Reporter)

Comment 1

2 years ago
Created attachment 8652314 [details]
Netmonitor on site http://gs.statcounter.com/#browser-ww-monthly-201301-201408.png

I guess you'll believe me about Devugger, but here's example of Netmonitor behavior
I believe this is a duplicate of bug 932317. Feel free to re-open if not.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 932317
(Reporter)

Updated

2 years ago
See Also: bug 1198250
(Reporter)

Updated

2 years ago
Has STR: --- → yes
You need to log in before you can comment on or make changes to this bug.