form doesn't submit (file upload)

RESOLVED DUPLICATE of bug 116210

Status

()

Core
HTML: Form Submission
RESOLVED DUPLICATE of bug 116210
17 years ago
17 years ago

People

(Reporter: Richard Jones, Assigned: justdave)

Tracking

Trunk
mozilla0.9.7
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The following HTML form will not submit in 0.9.7 unless the file field is 
actually used (ie. the user browses for and selects a file to be uploaded). If 
the submit button is hit without a file selection, it does nothing.

  <FORM ACTION="foo" METHOD="POST" enctype="multipart/form-data">
    <input type="file" name="file">
    <input type="submit">
  </form>

It needs to be changed to have a name attribute on the submit input before it 
will actually submit. Any name will do.
(Reporter)

Updated

17 years ago
Component: Administration → Form Submission
Product: Bugzilla → Browser
Target Milestone: --- → mozilla0.9.7
Version: unspecified → other
Known bug in 0.9.7 please upgrade -- it's fixed in latest cvs.

*** This bug has been marked as a duplicate of 116210 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.