Taking a full page screenshot fails on long pages (e.g. Loop's ui-showcase)

RESOLVED DUPLICATE of bug 766661

Status

RESOLVED DUPLICATE of bug 766661
3 years ago
17 hours ago

People

(Reporter: standard8, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

3 years ago
Loop's ui showcase is currently about 36k pixels tall (width around 1k pixels).

When we try to take a full page screenshot using devtools, nothing happens. If we cut down the size of the page, then it takes a screenshot just fine.

We should probably cut down our size sometime, but we haven't decided how to split it up yet. It does seem that the screenshot should really work as long as memory allows.

This could be an issue with canvas - according to my quick look, however, filing here as there may be things for devtools can do to workaround or help fix.

On a debug build we're getting:

console.error: 
  Message: [Exception... "Failure"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/commands/screenshot.js :: createScreenshotData :: line 293"  data: no]
  Stack:
    createScreenshotData@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/commands/screenshot.js:293:3
captureScreenshot@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/commands/screenshot.js:225:12
exports.items<.exec@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/commands/screenshot.js:207:14
Requisition.prototype.exec/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/cli.js:2083:16
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:239:18
Task_spawn@resource://gre/modules/Task.jsm:164:12
exports.exec@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/util/host.js:71:10
Requisition.prototype.exec@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/cli.js:2082:14
Requisition.prototype.updateExec/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/cli.js:2122:12
promise callback*Requisition.prototype.updateExec@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/gcli/cli.js:2121:1
promise callback*GcliActor<.execute<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/gcli.js:116:12
actorProto/</handler@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/protocol.js:1013:19
DSC_onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js:1591:15
LocalDebuggerTransport.prototype.send/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/transport/transport.js:569:11
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:83:14
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:83:14
(Reporter)

Comment 1

3 years ago
This doesn't load everything on the page, but it does allow reproduction of the failure:

http://hg.mozilla.org/mozilla-central/raw-file/23a04f9a321c/browser/components/loop/ui/index.html
Yes, this is a long standing issue with the screenshot code path.  This seems like the same case as bug 766661, so duping to that one.

If it's in fact different, please re-open.  If you have ideas on how we should best resolve this, we'd be happy to hear it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766661

Updated

3 months ago
Product: Firefox → DevTools

Updated

17 hours ago
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.