password not being filled in using "Fill Password" via the context menu in twitch.tv iframe

RESOLVED DUPLICATE of bug 1278158

Status

()

defect
P1
normal
RESOLVED DUPLICATE of bug 1278158
4 years ago
3 years ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

43 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 affected)

Details

()

Attachments

(1 attachment)

Reporter

Description

4 years ago
Filling in the password via the "Fill Password" under the context menu doesn't work under twitch.tv's login iframe. If you select the username from the field, the password gets auto filled without any problems but doesn't work via the context menu.

OS's:

- Win 10 x64 (VM) -> Reproduced
- OSX 10.10.5 x64 -> Reproduced

STR:

- load http://www.twitch.tv and select "Login"
- you should receive an iframe that points to https://passport.twitch.tv/
- insert your username/password and login
- once logged in, "Remember" the password via the doorhanger and logout
- load http://www.twitch.tv and select "Login"
- your credentials should be filled in (remove the password)
- right click on the password field and fill in the password using the "Fill Password" context menu (you should see an entry for the account you used earlier)

You'll notice that the password isn't being filld into the password field when going through the "Fill Password" context menu. However if you select the username from the username field, the password will get filled in without any issues.

Used the following builds
- https://archive.mozilla.org/pub/firefox/nightly/2015-08-25-03-02-12-mozilla-central/
- https://archive.mozilla.org/pub/firefox/nightly/2015-08-25-00-40-08-mozilla-aurora/
Reporter

Comment 2

4 years ago
Posted file log.txt
Attached the requested log. Logged the following workflow:

- clicked on "Login" via twitch.tv
- credentials that have been saved were filled in correctly
- deleted the password from the password field
- tried filling in the password via the context menu
Flags: needinfo?(kjozwiak)
> fillForm: There is no login form anymore. The form may have been removed or the document may have changed. LoginManagerContent.jsm:468
looks relevant. There's probably a bug in that logic or the page is constantly changing.
Priority: -- → P1
I think this was fixed by bug 1278158.

I confirmed I can repro on a 2015-08-25 Nightly but can't on today's Nightly.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1278158
You need to log in before you can comment on or make changes to this bug.