Cannot install new add-on format using WebIDE

RESOLVED DUPLICATE of bug 1196734

Status

DevTools
WebIDE
RESOLVED DUPLICATE of bug 1196734
3 years ago
9 days ago

People

(Reporter: mikehenrty, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

There are various problems here.

1.) WebIDE requires a file named manifest.webapp, which add-ons do not (and should not since it's confusing)

2.) WebIDE requires an "app starting document" defaulting to index.html. Add-ons have no concept of this.

3.) AFAICT WebIDE does not know how to parse an add-ons update manifest and determine if it is indeed an add-on vs. a normal app. B2G does this by checking for the existence of `manifest.json` in the package. Perhaps we need a completely separate UI flow in WebIDE to handle add-ons.


Ideally the flow would be to use the project/app dropdown from the upper left, and select "Open add-on". Barring that, it would be nice if "Open Packaged App" would work for a directory containing an add-on.
I believe should be coming soon!  Let's depend on bug 1196734.
Depends on: 1196734
Oh! I didn't know about that bug! Let's just dupe it since it looks like that gives us what we need.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196734

Updated

9 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.