[RFE] The FTP error messages should be more descriptive

RESOLVED WORKSFORME

Status

()

Core
Networking: FTP
P3
enhancement
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Michal 'hramrach' Suchanek, Assigned: dougt)

Tracking

({polish})

Trunk
Future
x86
Linux
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I had problems with NW4 FTP server for long reported as bug 70444 until I could
use tcdump which showed the server fails to accept PASV. The errors returned by
mozilla differed from version to version but only tcpdump could reveal where the
problem was. I could get one of these:
-nothing, either throbber throbs forever or it stops but the page does not change
-login error
-command not understood

The last error copies the server response verbatim which is the best from above
but does not indicate which command failed.

expected solution: display both the command that failed and the server respose

example one: display PASV failed in a message box and render the server response
as the content of the window

example two: display either the command or the server response in a message box
with a button which could open a window with full log of the communication with
server.
Yeah, fair enough. I need to add "The server said" or something like that to the
top so that people realise that its not our text, as well.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
Priority: -- → P3
Target Milestone: --- → mozilla1.0
Actually, ftp really shouldn't be putting up these promps at all, since that
interferes with stuff like publisher, whcih wants to handle errors itsself. We
shoiuld just return teh appropriate error codes instead.

-> 1.1
Target Milestone: mozilla1.0 → mozilla1.1beta
(Reporter)

Comment 3

17 years ago
I do not know what shoud be putting the propmts, but IMO they should be
displayed and supply all the information available in the end. 
Reading the above comment it seems there may be actually two problems:
networking stuff displaying some terse dialogs which it shouldnt and browser UI
_not_ responding to FTP errors at all.
But these are tightly coupled then.

Updated

16 years ago
Severity: minor → enhancement
Summary: The FTP error messages should be more descriptive → [RFE] The FTP error messages should be more descriptive

Comment 4

16 years ago
I think there have been recent improvements in this area, when I run the
functional test, I get more literal messages about passive support, too many
users, etc.

What areas need more information?

Asa demo'd an ftp feature for me once where the entire FTP control session was
logged in a split pane at the bottom of the screen.
I have no time to work on mozilla at the moment, so dougt is taking over FTP

open ftp bugs -> him
Assignee: bbaetz → dougt
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.1beta → Future
(Reporter)

Comment 6

16 years ago
Last time I got an FTP error I could tell what failed from the dialog text.
So for me the bug is generally fixed.

Comment 7

16 years ago
RESOLVED:WFM
Michal: as reporter, if you could VERIFY this, that would be great. Lets create
new bugs for any new situations w/o good error messages.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.