IonMonkey: MIPS32: Fix calculate frame size in generateEnterJIT

RESOLVED FIXED in Firefox 43

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: hev, Assigned: hev)

Tracking

unspecified
mozilla43
Other
Linux
Points:
---

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
/tmp/js.32 -f run-richards.js
Segmentation fault (core dumped)
(Assignee)

Comment 1

3 years ago
Created attachment 8652838 [details] [diff] [review]
0001-IonMonkey-MIPS32-Fix-calculate-frame-size-in-generat.patch
Attachment #8652838 - Flags: review?(nicolas.b.pierron)
(Assignee)

Updated

3 years ago
Assignee: nobody → r
Attachment #8652838 - Flags: review?(nicolas.b.pierron) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Comment 5

3 years ago
(In reply to Carsten Book [:Tomcat] from comment #3)
> sorry had to back this out in
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=6782a855c243 seems one of this changes caused a bustage
> like:
> 
> https://treeherder.mozilla.org/logviewer.html#?job_id=13496016&repo=mozilla-
> inbound

Sorry, it's my mistake, It caused by Bug 1198628. I will trying build with -Werror=sign-cmopare and fix that.
Flags: needinfo?(r)
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/847b92f43fc1
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.