Unable to add dtml method or dtml document with zope

VERIFIED DUPLICATE of bug 116210

Status

()

VERIFIED DUPLICATE of bug 116210
17 years ago
11 years ago

People

(Reporter: Thomas.Renard, Assigned: jst)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
It is not possible to add an dtml-method or dtml-document with the zope manage UI.

The form of the adding menu can be commited but then there is no response anymore.

The form looks like this, sorry, do not know if you have a zope...:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<head>
<title>Zope</title>
<link rel="stylesheet" type="text/css" href="/manage_page_style.css">

</head>
<body bgcolor="#ffffff" link="#000099" alink="#000099" vlink="#000099">


<table width="100%" cellpadding="2" cellspacing="0" border="0">
<tr class="location-bar">
<td align="left" valign="top">
<div class="form-title">
Add DTML Method
  </div>
</td>
<td align="right" valign="top">
<div class="std-text">
<a
href="http://localhost/HelpSys?help_url=/Control_Panel/Products/OFSP/Help/DTML-DocumentOrMethod_Add.stx"
onClick="window.open('http://localhost/HelpSys?help_url=/Control_Panel/Products/OFSP/Help/DTML-DocumentOrMethod_Add.stx','zope_help','width=600,height=500,menubar=yes,toolbar=yes,scrollbars=yes,resizable=yes').focus();
return false;" onMouseOver="window.status='Open online help'; return true;"
onMouseOut="window.status=''; return true;">Help!</a>
</div>
</td>
</tr>
</table>


<p class="form-help">
A DTML Method is used to hold scripting tags and text content.
It can contain HTML, XML, plain text, structured-text, etcetera.
A DTML Method can contain
<a href="http://www.zope.org/Documentation/Guides/DTML/">DTML
scripting tags</a> which operate in the context of the DTML Method's
containing object.
A DTML Method differs from a DTML Document in that it does not 
have properties and calls methods on its container object.
</p>

<p class="form-help">
You may create a new DTML Method object using the form below. 
 You may also choose to upload an existing html file from your
 local computer by clicking the <i>Browse</i> button.
</p>

<form action="addDTMLMethod" method="post" enctype="multipart/form-data">
<table cellspacing="0" cellpadding="2" border="0">
<tr>
<td align="left" valign="top">
<div class="form-label">
Id
    </div>
</td>
<td align="left" valign="top">
<input type="text" name="id" size="40" />
</td>
</tr>
<tr>
<td align="left" valign="top">
<div class="form-optional">
Title
    </div>
</td>
<td align="left" valign="top">
<input type="text" name="title" size="40" />
</td>
</tr>
<tr>
<td align="left" valign="top">
<div class="form-optional">
File
    </div>
</td>
<td align="left" valign="top">
<input type="file" name="file:string" size="25" value="" />
</td>
</tr>
<tr>
<td align="left" valign="top">
</td>
<td align="left" valign="top">
<div class="form-element">
<input class="form-element" type="submit" name="submit" 
     value=" Add " /> <input class="form-element" type="submit" name="submit" 
     value=" Add and Edit " />
</div>
</td>
</tr>
</table>
</form>

</body>
</html>


it is interesting, that all other document types (like images) can be added...

Another interesting thing: The DOM-Inspector is not able to show the DOM-Tree of
 this document!

Comment 1

17 years ago
Bug 119168: DOM Inspector is broken. sorry
I'm assuming you're using Mozilla 0.9.7?  Of course I couldn't ever know to help
you because you didn't say.  We put out versions daily (sometimes two or three
times daily) so it's important to know what you are using.  Please take some
time to read http://www.mozilla.org/quality/bug-writing-guidelines.html 

In any case, if you *are* using 0.9.7, then the release notes
http://www.mozilla.org/releases/mozilla0.9.7/ (which we spend time writing in
the hopes that people read them) say:

Mozilla will hang when submitting forms which have a field to upload files if
this field is blank or refers to an invalid file. This affects sites using Zope
or IMP webmail, among others. If you need this feature, you can download a
nightly build here: http://ftp.mozilla.org/pub/mozilla/nightly/latest/   (Bug
116210)
Ok I got e-mail from the reporter:

>Hey, I´m sorry because of not RTFM. But thank you for your patience with
>people like me  :-) 
>(of course I *am* using the 0.9.7)

So this bug then is in fact a dupe of 116210 :)


*** This bug has been marked as a duplicate of 116210 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.