Add HTTP request/response logging (or viewer)

VERIFIED DUPLICATE of bug 27119

Status

SeaMonkey
General
--
enhancement
VERIFIED DUPLICATE of bug 27119
17 years ago
14 years ago

People

(Reporter: Sergey V. Udaltsov, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla is a great tool for web development. With DOM inspector and JavaScript
console and debugger - it already way ahead of IE and others.

But for development of meta-sites, it would be very useful to have possibility
to see exactly HTTP requests and responses sent by mozilla. I think it is not a
big task (for the start, just logging to the text file would be nice).

Comment 1

17 years ago
Vinay Badami (badami@netscape.com) gave me the following information:

set NSPR_LOG_MODULES=nsHttp:2 will generate request response chunks...

request [
GET /blah HTTP/1.1
Host: ...
...
]
response [
HTTP/1.1 200 OK
Date: ...
...
]

set NSPR_LOG_MODULES=nsHttp:5  will generate a complete http LOG() spew.

set NSPR_LOG_FILE=http.log  to redirect the output to a file

Comment 2

17 years ago
see Bug 27119 "[RFE] http log traffic and headers"
Duping to bug 27119.  Add UI suggestions there.

*** This bug has been marked as a duplicate of 27119 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v dupe
Status: RESOLVED → VERIFIED
QA Contact: doron → tever
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.