Closed Bug 1199036 Opened 4 years ago Closed 2 years ago

Figure out a way to identify the right pContent in firefox desktop

Categories

(Core :: DOM: Content Processes, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1300112
Tracking Status
firefox43 --- affected

People

(Reporter: robertbindar, Unassigned)

References

Details

When we want to send a message from the parent process to a ServiceWorker living in a child process we need to know which one of the pContents represents the right process in which the ServiceWorker lives.

Currently, in Push API for instance, we broadcast the message to all the child processes.
Blocks: 1182117
See Also: → 1297594
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1300112
See Also: → 1501156
You need to log in before you can comment on or make changes to this bug.