Closed Bug 1199120 Opened 5 years ago Closed 4 years ago

Overlapping buttons in conversation window

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
1

Tracking

(firefox41 unaffected, firefox42 unaffected, firefox43 fixed)

RESOLVED FIXED
mozilla43
Iteration:
43.3 - Sep 21
Tracking Status
firefox41 --- unaffected
firefox42 --- unaffected
firefox43 --- fixed

People

(Reporter: bogdan_maris, Assigned: Mardak)

References

Details

(Whiteboard: [visual refresh bug])

User Story

The conversation toolbar buttons should be hidden when edit context is displayed.

Attachments

(2 files, 1 obsolete file)

Affected builds:
- latest Nightly 43.0a1

Affected OS`s:
- Windows 7 32-bit
- Mac OS X 10.10.4
- Ubuntu 14.04 32-bit

STR:
1. Start Firefox
2. Start a conversation without context
3. Click 'Add some context' or 'Edit Context' button

Expected results: Based on mockup from bug 1179164 only Save button is available when entering Edit/Add context.

Actual results: Other buttons can be seen and hit when in Edit/Add context mode.

Notes:
1. This is not a regression, it was introduce once with the new buttons.
This might be helped with the work I'm doing on bug 1174702.
Depends on: 1174702
Bogdan, is this also an issue with FF41? Looking at the screen shot, the UI layout looks bad. Is the UI messed up only when there are more than on Hello conversation windows open? If so, I would not call it blocking 41 release and lean towards letting bug 1174702 fix right the trains rather than uplifting to Beta.
Flags: needinfo?(bogdan.maris)
I just tested and we haven't switched to the new toolbar layout in 41/42, so this doesn't affect those.
Blocks: 1179193
Rank: 19
Priority: -- → P1
Blocks: 1179164
No longer blocks: 1179193
Flags: needinfo?(bogdan.maris)
Sevaan: should the buttons be simply hidden behind the edit conversation overlay, even if you're in the call?
(In reply to Mark Banner (:standard8) from comment #4)
> Sevaan: should the buttons be simply hidden behind the edit conversation
> overlay, even if you're in the call?
Flags: needinfo?(sfranks)
(In reply to Mark Banner (:standard8) from comment #4)
> Sevaan: should the buttons be simply hidden behind the edit conversation
> overlay, even if you're in the call?

Yes, please!
Flags: needinfo?(sfranks)
Points: --- → 1
Whiteboard: [visual refresh bug]
User Story: (updated)
Duplicate of this bug: 1204098
I'll fix this as I'm also working on bug 1184940.
Assignee: nobody → edilee
Status: NEW → ASSIGNED
Attached patch v1 (obsolete) — Splinter Review
Attachment #8661702 - Flags: review?(standard8)
Comment on attachment 8661702 [details] [diff] [review]
v1

Review of attachment 8661702 [details] [diff] [review]:
-----------------------------------------------------------------

Yep, I like this approach.
Attachment #8661702 - Flags: review?(standard8) → review+
Blocks: 1184940
Attached patch v1.1Splinter Review
Rebased on top of bug 1199213 removing ConversationView.
Attachment #8661702 - Attachment is obsolete: true
Iteration: --- → 43.3 - Sep 21
https://hg.mozilla.org/mozilla-central/rev/5ba16725d39c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.