Difficult to locate /about/ pages from mozorg home page.

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: agibson, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1838190] , URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
From the webdev mailing list while discussing the recent removal of Tabzilla:

"This now means that it's almost impossible to reach some pieces of the mozilla.org website because there is no menu any more. Try for example to get to the page that lists Mozilla leadership. Can you tell me how I can click myself through to that in an obvious way from the mozilla.org front page? I'm sure there's quite a few more examples like this."

I think this is a very valid point. I don't think the issue is caused by the removal of Tabzilla specifically, but it underlines a bigger discover-ability issue for the pages under /about/ from the mozorg home page.

Before the last home page redesign I'm pretty sure a link to "About" used to live in the main navigation at the top of the page, but it was removed for reasons that escape me.

Can we just add it back?
Yes!  Let's add About to the nav on the homepage temporarily.

The fabulous new global navigation that was originally going to launch with the full site redesign in late October will fix all these navigation problems when it finally launches sometime in q1 2016.
Whiteboard: [kb=1838190]

Comment 3

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/fbbd4132d73bcd69e3bb9af85dcb0986525e6d9b
Fix Bug 1199145, add about link to landing page

https://github.com/mozilla/bedrock/commit/8a952666e3c46336eeba9d3aef8163cf0bd0d049
Merge pull request #3289 from schalkneethling/bug1199145-difficult-to-locate-about-pages-from-landing-page

Fix Bug 1199145, add about link to landing page

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.