Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1199573
3 years ago
3 years ago

People

(Reporter: kentuckyfriedtakahe, Assigned: jya)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Steps to reproduce:

* Enable WebM MSE
* Navigate to link

Actual results:

Playback stalls at 19 seconds

Expected results:

Video plays through
(Assignee)

Updated

3 years ago
Assignee: nobody → jyavenard
(Assignee)

Comment 1

3 years ago
what resolution was it using at the time?

can you reproduce if you force the resolution to a specific value ; if so, which resolution?
Flags: needinfo?(ajones)
(Assignee)

Comment 2

3 years ago
WFM with any of the resolutions.

I try with the following:
start the video, let it play sees if it stalls @19s : nope
Seek to 0, set resolution to [240,360,480], let it play to see if it stalls at 19s: nope.
(Assignee)

Comment 3

3 years ago
I reproduced it, but not a stall, just no audio:

Dumping data for demuxer 1461deab0:
		Dumping Audio Track Buffer(audio/mp4a-latm): - mLastAudioTime: 17.716825
			NumSamples:10596 Size:6384370 NextGetSampleIndex:763 NextInsertionIndex:10596
			Buffered: ranges=[(0.000000, 20.015600), (40.007959, 266.031020)]
		Dumping Video Track Buffer(video/webm; codecs=vp9) - mLastVideoTime: 17.184000
			NumSamples:6377 Size:10799089 NextGetSampleIndex:412 NextInsertionIndex:6377
			Buffered: ranges=[(0.000000, 265.973000)]

what is very surprising however, is that it didn't stall despite the lack of audio, it should have
(Assignee)

Comment 4

3 years ago
STR:
Seek to 0. Pause.
Change resolution to 360p.

It's the 360p stream that has issues.
(Assignee)

Comment 5

3 years ago
The cause for the stall is bug 1199573.

However, with that fixed, I now get a demuxing error upon parsing video range 194611000 to 195194000.
Looks like 360p is your resolution of choice. I must have a slow Internet connection or at least competition for using it.
Flags: needinfo?(ajones)
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1199573
You need to log in before you can comment on or make changes to this bug.