Closed Bug 1199778 Opened 6 years ago Closed 5 years ago

test_classifier.html | uncaught exception - NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIUrlClassifierDBService.beginUpdate] at chrome://specialpowers/content/specialpowersAPI.js:162

Categories

(Toolkit :: Safe Browsing, defect, P2)

43 Branch
x86
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1289028
Tracking Status
firefox43 --- affected

People

(Reporter: kaustabh93, Assigned: dimi)

References

Details

This test fails with runByDir & is suspected to fail otherwise too : Bug 1084261 

Here is a push to try : https://treeherder.mozilla.org/#/jobs?repo=try&revision=b6cc170ef866&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified&filter-searchStr=linux%20debug%20m%285%29

03:11:14     INFO -  1723 INFO SimpleTest START
03:11:14     INFO -  1724 INFO TEST-UNEXPECTED-FAIL | toolkit/components/url-classifier/tests/mochitest/test_classifier.html | uncaught exception - NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIUrlClassifierDBService.beginUpdate] at chrome://specialpowers/content/specialpowersAPI.js:162
03:11:14     INFO -      simpletestOnerror@SimpleTest/SimpleTest.js:1517:11
03:11:14     INFO -      OnErrorEventHandlerNonNull*@SimpleTest/SimpleTest.js:1504:1
03:11:14     INFO -  JavaScript error: chrome://specialpowers/content/specialpowersAPI.js, line 162: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIUrlClassifierDBService.beginUpdate]
03:11:14     INFO -  ++DOCSHELL 0x98dd2400 == 8 [pid = 4593] [id = 8]
03:11:14     INFO -  ++DOMWINDOW == 20 (0x98dd3000) [pid = 4593] [serial = 20] [outer = (nil)]
03:11:14     INFO -  MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
03:11:14     INFO -  MEMORY STAT | vsize 572MB | residentFast 196MB | heapAllocated 60MB
03:11:14     INFO -  ++DOMWINDOW == 21 (0x9398e000) [pid = 4593] [serial = 21] [outer = 0x98dd3000]
03:11:14     INFO -  ++DOMWINDOW == 22 (0x97663c00) [pid = 4593] [serial = 22] [outer = 0x98dd3000]
03:11:14     INFO -  ++DOCSHELL 0x98dd4c00 == 9 [pid = 4593] [id = 9]
03:11:14     INFO -  ++DOMWINDOW == 23 (0x99021400) [pid = 4593] [serial = 23] [outer = (nil)]
03:11:14     INFO -  ++DOMWINDOW == 24 (0x992d0800) [pid = 4593] [serial = 24] [outer = 0x99021400]
03:11:14     INFO -  1725 INFO TEST-OK | toolkit/components/url-classifier/tests/mochitest/test_classifier.html | took 2861ms
03:11:14     INFO -  ++DOMWINDOW == 25 (0x9a429400) [pid = 4593] [serial = 25] [outer = 0x9433ac00]
Blocks: 1162003
as a note, this test has been disable for a short while on linux debug:
https://dxr.mozilla.org/mozilla-central/source/toolkit/components/url-classifier/tests/mochitest/mochitest.ini#19

:dcamp, can you make sure this is know by whomever would be the owner.
Flags: needinfo?(dcamp)
Flags: needinfo?(dcamp)
Priority: -- → P5
Priority: P5 → P2
Assignee: nobody → dlee
Status: NEW → ASSIGNED
This is the same root cause as bug 1289028.
Testcase update & Safebrowsing.jsm update have race condition.

It should have already been fixed in bug 1289028
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1289028
You need to log in before you can comment on or make changes to this bug.