browserAction popup doesn't seem to work in Nightly

RESOLVED FIXED in Firefox 43

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: wbamberg, Assigned: billm)

Tracking

unspecified
mozilla43
Points:
---

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8654417 [details]
borderify-button.xpi

I've attached a WebExtension that adds a browserAction with a popup attached. In my Nightly, the browserAction doesn't appear, and I see this in the console:

* [CustomizableUI] Custom widget with id borderify_mozilla_org-browser-action does not return a valid node CustomizableUI.jsm:166
* [CustomizableUI] Widget 'borderify_mozilla_org-browser-action' not found, unable to move CustomizableUI.jsm:166
* XUL_NS is not defined

In Chrome, the same extension works (if I remove the "applications" key from manifest.json). It works in Developer Edition as well (except that the popup is not resized to fit the content).
This regressed in bug 1198970.
Blocks: 1198970
Created attachment 8654436 [details] [diff] [review]
patch

That bug just removed a variable. It turned out it was used in ext-browserActions.js, which pulls in all the vars of Extension.jsm.

The test for this isn't great, but it's enough to detect the bad behavior here. I'm going to ask about a better way to do this when more frontend people are around. I'm not too familiar with CustomizableUI.jsm.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #8654436 - Flags: review?(gkrizsanits)
Duplicate of this bug: 1200668
Attachment #8654436 - Flags: review?(gkrizsanits) → review+
Duplicate of this bug: 1201097
https://hg.mozilla.org/mozilla-central/rev/6ede4c1ffefd
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.