[e10s] Breakpoints no longer hit inside actors from Browser Toolbox

RESOLVED WORKSFORME

Status

DevTools
Debugger
RESOLVED WORKSFORME
3 years ago
a month ago

People

(Reporter: jryans, Unassigned)

Tracking

(Blocks: 3 bugs)

Firefox Tracking Flags

(Not tracked)

Details

STR:

1. Open a in-tab toolbox
2. Open Browser Toolbox
3. Set a breakpoint in an actor
  * Such as highlighter.js#pick
4. Use the toolbox to perform an action that triggers the actor's method
  * Such as click the pick element button

ER:

Breakpoint hits.

AR:

No hit.

This is still working in 42, but broken in 43.

Will attempt a regression search soon.
(Reporter)

Updated

3 years ago
status-firefox42: --- → unaffected
status-firefox43: --- → affected
(Reporter)

Comment 1

3 years ago
I misinterpreted the results before.

Nothing has changed between 42 and 43.  Instead, the issue is that this fails for e10s windows.  It continues to work in 43 if you open a tab toolbox in a non-e10s window.

I'm fairly sure this has never worked for e10s windows.
Blocks: 875871
status-firefox42: unaffected → ---
status-firefox43: affected → ---
Keywords: regression, regressionwindow-wanted
Summary: Breakpoints no longer hit inside actors from Browser Toolbox → [e10s] Breakpoints no longer hit inside actors from Browser Toolbox
(Reporter)

Comment 2

3 years ago
And look at that... if you use the Browser Content Toolbox, it will stop.

Using the tools correctly helps!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.