Floated element inside table is badly aligned

VERIFIED FIXED in M15

Status

()

P3
normal
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: jeroen, Assigned: buster)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] hyp-x@inf.bme.hu, URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Look at the page. The table in the center does have thick black vertical lines (+/- 1.5 cm) and that's not supposed to happen.

Updated

19 years ago
Summary: Table layout messed up → Table layout messed up (involving right floated image)
Whiteboard: [TESTCASE] hyp-x@inf.bme.hu

Comment 1

19 years ago
There may be multiple problems with this page, since it has complicated
nested tables. One of the problems can be seen in the following example:
---
<table border>
  <tr>
    <td><img align="right" src="http://bugzilla.mozilla.org/ant.jpg"></td>
  </tr>
</table>
---
The table gets stretched to the width of the viewport because the image
is right-aligned to the viewport instead of the table cell. (Or so it seems.)

Comment 2

19 years ago
Created attachment 1275 [details]
Testcase

Updated

19 years ago
Summary: Table layout messed up (involving right floated image) → Floated element inside table is badly aligned

Comment 3

19 years ago
I've tested with
 <div style="float: right">foo</div>
instead of <img> to see the problem is applies generally to floated elements.

Updated

19 years ago
Assignee: troy → karnaze

Comment 4

19 years ago
Chris, the table cell ends up too wide. This may be a block problem, but I
figured we should start with tables.

I saw a similar bug recently, but I can't seem to find it

Updated

19 years ago
Assignee: karnaze → kipp

Comment 5

19 years ago
Kipp, I turned on the table reflow debug flags in nsTableFrame.h and it looks
like the cell's area frame is saying that its desired size is around
NS_UNCONSTRAINED_SIZE in the attachment. I've seen the same problem when a cell
contains an image that can't be found even though the cell has its width set.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
The test case now works dandy -- right floaters in table cells now work much
better.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
Fixed in the Sept 22nd build.
You need to log in before you can comment on or make changes to this bug.