Closed Bug 1200400 Opened 4 years ago Closed 4 years ago

Add support for switchToShadowRoot in JSMarionette.

Categories

(Testing Graveyard :: JSMarionette, defect)

defect
Not set

Tracking

(firefox43 affected)

RESOLVED FIXED
Tracking Status
firefox43 --- affected

People

(Reporter: yzen, Assigned: yzen)

References

Details

Attachments

(2 files)

Right now support for web components is only present in the Python client for Marionette. In order to be able to use it in JS we need the same level of support in JS client.
Attachment #8655561 - Flags: review?(gaye)
Hi Gareth, would you be able to take a look at this one? Gaia-components integration testing will be possible with this one. Also, let me know what needs to be done to update the version so it can be used externally from Gaia.
Flags: needinfo?(gaye)
I don't have a ton of free time at the moment, but I'll leave myself ni? for now so it's on my radar.
Flags: needinfo?(gaye)
Flags: needinfo?(gaye)
Ohh there's a patch!
Flags: needinfo?(gaye)
Would it be easy to add an integration test for this?
Hi Gareth, took care of the tests. Could you take a look again?
Flags: needinfo?(gaye)
(In reply to Yura Zenevich [:yzen] from comment #0)
> Right now support for web components is only present in the Python client
> for Marionette. 

Oh, how can I make use of this from the python side of things?
(In reply to Martijn Wargers [:mwargers] (QA) from comment #7)
> (In reply to Yura Zenevich [:yzen] from comment #0)
> > Right now support for web components is only present in the Python client
> > for Marionette. 
> 
> Oh, how can I make use of this from the python side of things?

Python client already has switch_to_shadow_root since it's part of gecko, here are examples from tests:
https://github.com/mozilla/gecko-dev/commit/75c928c716a6e26162e42623db0cb60ccccf9c71#diff-413c9c7257267b3d931005d4dcdaaa84
Comment on attachment 8655561 [details] [review]
[gaia] yzen:bug-1200400 > mozilla-b2g:master

Thanks for yet another nice patch yzen :)
Flags: needinfo?(gaye)
Attachment #8655561 - Flags: review?(gaye) → review+
Landed on master https://github.com/mozilla-b2g/gaia/commit/b3f438d97d21f0f8f7d45ec4d7376978a3cb379a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1194296
Two questions: 

1. can we get the documentation updated? I'm using this one http://mozilla-b2g.github.io/marionette-js-client/api-docs/classes/Marionette.Client.html and it is not up to date

2. how do we restore the non shadow document root?
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.