Conversation won't update if SMS is received while save-draft dialog is visible.

RESOLVED DUPLICATE of bug 1176976

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 1176976
3 years ago
2 years ago

People

(Reporter: mhoye, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
If I receive an SMS while the SMS app is asking me to save my current message as a draft, the conversation window will not update to show the new SMS.

I need to close the application and restart it for that message to display.
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Comms triage: Edge case that might have not been considered. QA wanted for a branch check. If that's a regression, please renominate.
blocking-b2g: 2.5? → ---
Keywords: qawanted
Note that we'll remove this dialog in bug 1176976 anyway... But there could be a race.
Also this might come from the patch in bug 1162030.

Updated

3 years ago
QA Contact: ddixon
Branch Check

This bug is not a regression. 

Issue DOES occur in Aries 2.5, Flame 2.5 and Flame 2.2 builds.  

Actual Results: If the user is at the "Save as Draft or Delete Draft" dialogue, receives a new SMS, then selects "Cancel" to go back to the message thread, the newly received message is not visible.  The message thread does not update unless app is closed/reopened.   

Device: Aries 2.5
BuildID: 20150902124951
Gaia: e2fab8f6ac345ecde10a1350e699be9ceb6987d6
Gecko: 1b687fcb5213153855c7ac0f8392ce0a4a7e3382
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.5 (eng. build)
BuildID: 20150902045425
Gaia: e2fab8f6ac345ecde10a1350e699be9ceb6987d6
Gecko: 1b687fcb5213153855c7ac0f8392ce0a4a7e3382
Version: 43.0a1 (Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.2 (eng. build)
BuildID: 20150901092824
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: c03e2bc6a3a4
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Attaching a logcat in case it is useful...
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Created attachment 8656108 [details]
thread_update_fail_logcat.txt

Updated

3 years ago
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Mike, I believe you'll see the message if you go back to inbox and then enter the conversation again (I mean, no need to restart the app). Does it work like that ?
Found the issue: we call stopRendering too early, see [1].
This blocks any rendering in the conversation.

I think we should call it in a "then" method in [2].

[1] https://github.com/mozilla-b2g/gaia/blob/63347c4fe673b6624400c816f7c455a0a4fef004/apps/sms/views/conversation/js/conversation.js#L1224

[2] https://github.com/mozilla-b2g/gaia/blob/63347c4fe673b6624400c816f7c455a0a4fef004/apps/sms/views/conversation/js/conversation.js#L1266

I'm currently reviewing bug 1176976 but this may take more time to land. If anybody wants to fix this issue first we can review it (please ask a review to schung :) ).
(Reporter)

Comment 8

3 years ago
Julien - if I can reproduce the issue, I'll try that to verify.
bug 1176976 landed, so duping.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1176976
You need to log in before you can comment on or make changes to this bug.