Rendering issues with opacity: using skia in Nightly

RESOLVED FIXED in Firefox 51

Status

()

Core
Graphics
RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: beta, Assigned: lsalzman)

Tracking

(Blocks: 1 bug, {reproducible})

42 Branch
mozilla51
reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 fixed)

Details

(Whiteboard: gfx-noted)

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8655520 [details]
Screenshot.2015-09-01.170701.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150831004018

Steps to reproduce:

Visited https://steamlug.org/mumble in 43.0a1 with gfx.content.azure.backends set to skia


Actual results:

The Mumble list of users uses css opacity to make channels and subchannels less intense. However with the skia renderer, this is making the background darker as well.


Expected results:

Unlike Firefox with cairo, and Chromium, this appears incorrect.
(Reporter)

Comment 1

2 years ago
Created attachment 8655529 [details]
small-testcase.html

Put together an offline reproduction of that behaviour

Updated

2 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
Tentatively hanging this off bug 1007702 as well in case it's not Linux specific.
Blocks: 1038800, 1007702

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible
Whiteboard: gfx-noted
(Assignee)

Comment 3

a year ago
Upstream bug report with proposed fix: https://codereview.chromium.org/2097883002
(Assignee)

Comment 4

a year ago
Created attachment 8778433 [details] [diff] [review]
revise Skia row blits to preserve color when blended against itself

This is a port of work I did in upstream Skia to fix this issue: https://skia.googlesource.com/skia/+/40254c2c2dc28a34f96294d5a1ad94a99b0be8a6

Also some tests needed to be fuzzed due to the slight differences in blending.
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Attachment #8778433 - Flags: review?(mchang)
Attachment #8778433 - Flags: review?(mchang) → review+

Comment 5

a year ago
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ffd7f9c1bbf9
revise Skia row blits to preserve color when blended against itself. r=mchang

Comment 6

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ffd7f9c1bbf9
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
(Assignee)

Updated

10 months ago
Blocks: 1325259
You need to log in before you can comment on or make changes to this bug.