CSS property background, inheritance and scrolling

VERIFIED DUPLICATE of bug 1045

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 1045
19 years ago
2 years ago

People

(Reporter: walter, Assigned: troy)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
<html>
<style>
body
{
	background-color: white;
}
td.gurk
{
	background: url("local.gif") top left repeat-x fixed;
}
</style>
<body>
<table width="100%" height="100%">
<tr><td>Hurz</td><td class="gurk">very long text that forces the browser window
to be scrolled</td></tr>
</body>
</html>

(local.gif is an arbitrary image)

When viewing this web page and the page is large enough
that the complete content of the second table cell
is displayed the background of the table cell is not
inherited from the body background.

When the page is small enought that the content can be
scrolled part of the scrolled page is not repainted.

(this happens with the 19990814 build of Mozilla.
(Assignee)

Updated

19 years ago
Assignee: troy → karnaze
(Assignee)

Comment 1

19 years ago
Chris, I'm going to leave this to you to resolve. The reason we scroll
vertically is because the table has an explicit height of "100%". There must be
table specific code that's handling that, because the normal HTML reflow state
code would reset the height to 'auto' because the BODY's height is 'auto'

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 2

19 years ago
I just fixed the percentage height problem. I couldn't see the other problems
reported.

Updated

19 years ago
QA Contact: petersen → chrisd
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 3

19 years ago
Take a look at
http://www.catsystems.de/~walter/AMIGA/ZT_DockBrushes/Gallery.html
scroll down the page to the buttom and then scroll up again (via mouse)
On the right hand side of the page the background doesn't get repainted.

Updated

19 years ago
Resolution: FIXED → ---

Updated

19 years ago
Assignee: karnaze → troy
Status: REOPENED → NEW

Comment 4

19 years ago
Troy, I don't think the remaining problem (8/23 comments) is table related. I'm
not sure who else to give it to.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
The issue is that there are fixed background attachment images inside of the
table. We currently have a bug that this doesn't work for nested elements, i.e.
it works fine for the element actually being scrolled but not one of its child
elements

That's a DUP of bug #1045.

Once bug #1045 is fixed if this still doesn't work, then Chris you need to make
sure that table cells also support fixed background attachments. I don't know
whether they do or don't, but the main thing is that in that case the frame
needs a view and the NS_VIEW_PUBLIC_FLAG_DONT_BITBLT needs to be set

*** This bug has been marked as a duplicate of 1045 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Verified dup of #1045
You need to log in before you can comment on or make changes to this bug.