[SMS] Blank white screen occurs after user discards a new text message

RESOLVED DUPLICATE of bug 1187117

Status

Firefox OS
Gaia::System::Window Mgmt
P1
normal
RESOLVED DUPLICATE of bug 1187117
2 years ago
2 years ago

People

(Reporter: ddixon, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe], URL)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8655623 [details]
white_screen_sms_logcat.txt

Description:
If the user searches a phone number in the rocket bar with "sms: [any number]", the Messages app is opened.  Pressing  "X">Delete draft causes a white screen to appear with only the status bar at the top.  A wifi or data connection is not needed to repro this bug. 

Repro Steps:
1) Update a Flame to 20150901053324
2) Tap on rocket bar and search "sms: 5"
3) After Messages app opens, press "X" in upper left corner
4) Select "Delete draft" 

Actual:
User is taken to a blank white screen after searching "sms: [any number]" with rocket bar then deleting the message draft. 

Expected:
Deleting any message draft does not reveal a blank white screen. 

Environmental Variables:
Device: Flame 2.5
Build ID: 20150831030202
Gaia: 31e595f86f6bf159b3a9a46816a6ac00a55ca9f9
Gecko: f2518b8a7b97b5bb477e94bc9131584007aac887
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 10/10 

See attached: logcat, video (http://youtu.be/kmTlvt9nJ-k)
(Reporter)

Comment 1

2 years ago
Issue DOES occur in latest Flame 2.5, 2.2 (shallow flash, engineering) builds. 

Device: Flame 2.5
BuildID: 20150901053324
Gaia: 805025801a68f9ddbba6ffd2ed3926c97fa7fcc8
Gecko: dd509db16a138beb777599662ad88e3207bc2d2c
Version: 43.0a1 (Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.2
BuildID: 20150901064340
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: d91926669834
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------
This issue does not occur on Aries 2.5 because it is currently blocked by Bug 1200538.

Device: Aries 2.5
Build ID: 20150812231434
Gaia: 52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gecko: 7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Whiteboard: [2.5-Daily-Testing]
Looks like a window management issue.
Component: Gaia::SMS → Gaia::System::Window Mgmt
(Reporter)

Comment 3

2 years ago
---Correction for Comment 1--- 

This issue DOES occur in the latest Aries 2.5 build and is NOT blocked by bug 1200538.

Device: Aries Master
Build ID: 20150901190824
Gaia: c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gecko: e47423c019643792e6de894cfcee598dead4d3ba
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
(Reporter)

Updated

2 years ago
Whiteboard: [2.5-Daily-Testing] → [2.5-Daily-Testing][Spark]
Alison would you block on this issue?  Julien says its a windows management issue in comment 2.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ashiue)

Comment 5

2 years ago
[Blocking Requested - why for this release]:
Obvious problem

Hi Gregor, 

Could you help to check or dispatch this issue to suitable person? Thank you.
blocking-b2g: --- → 2.5?
Flags: needinfo?(ashiue) → needinfo?(anygregor)

Updated

2 years ago
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][Systemsfe]
Blocking for 2.5 with P1 priority.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P1
I didn't even know this sms feature existed and it's not a regression from 2.2. I don't think its a P1 blocker and I don't even believe its a blocker based on our criteria. That seems more like a corner case but I agree that we should fix it for 2.5.
Flags: needinfo?(anygregor)
Wondering what happens with the following cases:

A. From the rocketbar:
* mailto: URLs
* tel: URLs

B. From the Browser:
* mailto:, tel:, sms: URLs

Could QA try these URLs from the rocketbar (A) ? Can you also write test HTML files to check cases B ? We simply need HTML pages containing links with these URLs as href, to check how these links work.
Keywords: qawanted
Created attachment 8659591 [details]
URI-Test-Links.html
Scenario A: All link types are affected.
'mailto', 'sms', and 'tel' links all produce this same blank screen behavior. This has actually been written previously with regards to 'mailto' in bug 1187117.

Scenario B: Browser links are NOT affected.
'mailto', 'sms', and 'tel' links will all properly leave the browser running in the background and launch the appropriate app (e-mail, phone, messages) and populate the desired fields.

I’ve attached a really simple .html file to test the basic forms of these links, but there are a number of permutations of how these links might be found.

I also found these existing web pages for testing various permutations for the ‘sms’ and ‘mailto’ URIs:
mailto links - http://www.scottseverance.us/mailto.html
sms links - http://bradorego.com/test/sms.html

I was not able to find an existing page for testing ‘tel’


Environmental Variables:
Device: Aries 2.5
BuildID: 20150909215207
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Contact: mshuman
Apologies, that second set of environmental variables should be for the most recent Flame 2.5 device.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150910030223
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Thanks !
Then it's likely a dupe of bug 1187117. I'm not duping yet because that bug is not 2.5+. But I tend to agree with Gregor here. Renominating.
If it's not 2.5+ anymore after triaging, please dupe to bug 1187117.
blocking-b2g: 2.5+ → 2.5?
What happens once you're in that white screen state?  Can you get out of it?   Do you need to force close the messages app?  It's definitely a corner case to get there but that white screen state is concerning.
Flags: needinfo?(ddixon)
Kevin, Can you please help with this bug? Thanks
Flags: needinfo?(ktucker)
Setting qawanted tag to check comment 13.
Flags: needinfo?(ktucker)
Flags: needinfo?(ddixon)
Keywords: qawanted
(In reply to Peter Dolanjski [:pdol] from comment #13)
> What happens once you're in that white screen state?  Can you get out of it?
> Do you need to force close the messages app?

Pressing Home button gets out of this blank window and takes user back to Homescreen. Force close is not needed.

Tested on
Device: Aries 2.5
BuildID: 20150929110451
Gaia: f345f6a015709beeb2ca3955cab077fcaa959d3b
Gecko: acdb22976ff86539dc10413c5f366e1fb429a680
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.5
BuildID: 20150929030205
Gaia: f345f6a015709beeb2ca3955cab077fcaa959d3b
Gecko: acdb22976ff86539dc10413c5f366e1fb429a680
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Status: NEW → RESOLVED
blocking-b2g: 2.5? → ---
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1187117
You need to log in before you can comment on or make changes to this bug.