Closed Bug 1201096 Opened 7 years ago Closed 7 years ago

Remove WebRTC LSan suppressions

Categories

(Core :: WebRTC, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed

People

(Reporter: mccr8, Assigned: mccr8)

References

(Blocks 1 open bug)

Details

(Whiteboard: [MemShrink])

Attachments

(1 file)

Bug 1198107 seems to have fixed the suppressions I added for bug 1074310, and I also don't see the suppressions I added for bug 982111, so we should remove this so we catch any regressions.
I looked through a bunch of LSan logs and a number of WebRTC leaks seem to have gone away. There are also a few non-WebRTC leaks that have gone away it looks like, so I added them in, too.

The orange here is from a printer-related suppression I tried to remove, but I've kept it in this patch.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a90dc11a6d89
Attachment #8656185 - Flags: review?(erahm)
Oh, and I went through and marked the various bugs mentioned in these suppressions as WFM.
Comment on attachment 8656185 [details] [diff] [review]
Remove various obsolete LSan suppressions.

It looks like Eric is out for a bit, so I'll get njn to review.
Attachment #8656185 - Flags: review?(erahm) → review?(n.nethercote)
Comment on attachment 8656185 [details] [diff] [review]
Remove various obsolete LSan suppressions.

Review of attachment 8656185 [details] [diff] [review]:
-----------------------------------------------------------------

I'm still here! r=me, thanks for following up in all the bugs.
Attachment #8656185 - Flags: review?(n.nethercote) → review+
Keywords: checkin-needed
Comment on attachment 8656185 [details] [diff] [review]
Remove various obsolete LSan suppressions.

Review of attachment 8656185 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
backlog: --- → webrtc/webaudio+
Rank: 25
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.