Closed Bug 1201126 Opened 5 years ago Closed 5 years ago

1080p 60 FPS video stuttering and occasionally stopping playback

Categories

(Core :: Audio/Video: Playback, defect, P2)

42 Branch
Unspecified
Windows 7
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ssimon, Unassigned)

Details

(Whiteboard: [betabreakers-fx42])

Attachments

(16 files)

Attached file fx42_Zito_DxDiag.txt
Actual Results:
Streaming youtube video at 1080p 60fps in a tab while visiting other sites in additional tabs sometimes causes the video to stutter and not stream smoothly. Occasionally the video will stop playing with the loading icon on the video.

Expected Results:
Videos should stream smoothly and never halt playback in the middle of the video.

Steps to Recreate:
1 Launch browser, go to https://www.youtube.com/watch?v=TNOTBY9tbJI&list=PLkWk0GF3nOGJ0hKmY2ghHx3x4lX0aPKVY  switch playback quality to 1080p 60
2 In new tabs, visit https://maps.google.com/, https://www.flickr.com/explore, https://www.nytimes.com/, and http://us.battle.net/en/
3 Switch back to the video
4 Verify that sometimes the playback stutters, and occasionally will stop all together

NOTE: This is not reproducible 100% of the time.  It was seen once.
Whiteboard: [betabreakers-fx42]
Not sure if this is just related to the hardware not being up to par for 1080p 60fps streaming, but this was also seen on Dragonmaw.  

DxDiag and about:support logs attached.
This also occurred on Silvermoon.  Playback was stuttering and eventually stopped completely and did not recover.
Also occurred on Nefarian.  Files attached.
Also occurred on Skywall.  Files attached.
Also seen on Kal El
Attached file fx42_KalEl_DxDiag.txt
Also seen on Frostwolf.
Also occurred on Wario
Attached file fx42_Wario_DxDiag.txt
Are you sure this is Firefox and not network issues, or is that still to be determined?
Some systems were able to stream the content, many systems had some buffering issues due to hardware limitations, but the ones included on this bug were the systems that stopped playback and never recovered after several minutes.  I doubt it was a network issue as many systems using the same connection did not have problems.
Milan, could you have someone run through the test on the lab machines in Toronto to see if this is reproducible?
Flags: needinfo?(milan)
Retested. Slight hiccups when opening multiple tabs. Playback does always recover. Seems to be caused by hardware limitations and how browser, at least in this configuration. Tested on Firefox Dev 43.
(In reply to Trammel May from comment #20)
> Retested. Slight hiccups when opening multiple tabs. Playback does always
> recover. Seems to be caused by hardware limitations and how browser, at
> least in this configuration. Tested on Firefox Dev 43.

Correct, seems to be caused by hardware limitations and NOT browser.
Anthony, do you still see this as a valid bug report given comment 20?
Flags: needinfo?(milan) → needinfo?(ajones)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #22)
> Anthony, do you still see this as a valid bug report given comment 20?

I think we can close this bug on the basis that we've fixed a number of the perf issues since this bug was filed.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(ajones)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.