Closed Bug 1201192 Opened 6 years ago Closed 5 years ago

[APZ] Lots of checkerboarding / missing paints when scrolling network monitor

Categories

(Core :: Panning and Zooming, defect)

Unspecified
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jryans, Unassigned)

References

(Blocks 1 open bug, )

Details

When APZ is enabled (as it is for Mac on Nightly), the network monitor in DevTools has lots of checkerboarding and you can easily scroll enough that we never re-paint the request list at all.

STR:

1. Visit a site with many requests such as this demo: http://bgrins.github.io/devtools-demos/misc/requests.html
2. Open the net monitor quickly to catch requests (or reload once it is open): Tools -> Web Developer -> Network
3. Once at least ~200 requests have loaded, try to scroll using the touchpad
  * You can check the demo page, it lists a count of loaded requests

ER:

The list of requests in the net monitor should scroll smoothly.

AR:

With a large request list, scrolling easily triggers checkerboarding.  In some cases, the request list is even left unpainted (blank) forever.  Scrolling again slowly repaints it back again.

Disabling APZ by flipping "layers.async-pan-zoom.enabled" makes scrolling perf much better here.
OS: Unspecified → Mac OS X
I'm able to reproduce the perma-checkerboard using these STR on the latest OS X desktop nightly, although I have to scroll really aggressively to hit it. It seems like if the scroll position reaches the end of the scrollframe while it's in a temporary checkerboarding state, it doesn't do a repaint and remains perma-checkerboarded. We should definitely fix this.
Blocks: all-aboard-apz
No longer blocks: apz-desktop
No problem on Win8.1 (current win32 nightly)
Can you still reproduce this on the latest nightly? The scrolling behavior is quite bad before bug 1208554, and appears to have improved a lot after.

It wouldn't fix the problem in comment #1 but it should make it much harder to checkerboard.
Flags: needinfo?(jryans)
(In reply to David Anderson [:dvander] from comment #3)
> Can you still reproduce this on the latest nightly? The scrolling behavior
> is quite bad before bug 1208554, and appears to have improved a lot after.
> 
> It wouldn't fix the problem in comment #1 but it should make it much harder
> to checkerboard.

I agree with your evaluation.  It is much better in the general case.

It's still possible to perma-checkboard if you scroll aggressively, but it does seem harder to trigger that case.
Flags: needinfo?(jryans)
Since this is less frequent now I'm downgrading the importance of it with respect to shipping APZ.
Blocks: apz-desktop
No longer blocks: all-aboard-apz
It works for me in win 10 and mac 10.11 (OS X El Capitan).
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
My Test Environments:
-------------------
Version  47.0a1
Build ID  20160201030241
Update Channel  nightly
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0

and

Version 	47.0a1
Build ID 	20160201030241
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
I also can't hit the perma-checkerboarding any more, and in general this seems a lot better. :jryans, please reopen this if you still see it in Nightly.
I agree, it appears to be fixed.  I can't hit the perma-checkerboard either.

Great work, whoever fixed it! :)
You need to log in before you can comment on or make changes to this bug.