File/Print Preview hangs (inf. loop in nsBlockFrame::ReflowDirtyLines)

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Hyman Rosen, Assigned: rods (gone))

Tracking

({hang})

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Go to this page, and try to Print Preview.
Mozilla hangs, stopping to redraw itself.

Comment 1

17 years ago
I can reproduce this problem using 1/15 trunk build on Win 98 system.

Looks like this is a long web page. 

print preview immediately hangs.

Updated

17 years ago
Severity: normal → critical
Keywords: hang

Comment 2

17 years ago
I tested both on the given URL and on this bug page itself using
build 2002011103 on a Windows ME box with NVIDIA TNT2 based video.

On the given URL, I get an immediate hang.

On this bug page, print preview has garbage outside the print area and
inside the CC: list.

Comment 3

17 years ago
Confirmed with 2002-01-14-03 under W2K
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Summary: File/Print Preview hangs → File/Print Preview hangs (inf. loop in nsBlockFrame::ReflowDirtyLines)

Comment 4

17 years ago
Created attachment 65976 [details]
stack trace for hang in nsBlockFrame::ReflowDirtyLines

I also hit this infinite loop, viewing 
  http://www.newyorker.com/PRINTABLE/?fact/020128fa_FACT

The stack for the loop shows it's in nsBlockFrame::ReflowDirtyLines,
inside the large while loop:

  while (keepGoing && (nsnull != aState.mNextInFlow)) {
      ... looping in here ...
  }

Comment 5

17 years ago
To be clear, I get that stack trace when doing print preview for either
the ibm.com url or for the newyorker.com url.
(Assignee)

Comment 6

17 years ago
These no longer crash for me. marking as Works for me. Please reopen if necessary.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
Nope. Both no longer hang (current trunk win2k)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.