Closed Bug 1201781 Opened 4 years ago Closed 4 years ago

getuserMedia doorhangers are overwritten by subsequent calls to getUserMedia

Categories

(Firefox :: Site Permissions, defect)

40 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 861716

People

(Reporter: fippo, Unassigned)

References

()

Details

(Whiteboard: [getUserMedia])

Calling
navigator.mediaDevices.getUserMedia({audio:true})
navigator.mediaDevices.getUserMedia({video:true})
shows (for some milliseconds) the GUM doorhanger for the microphone and then shows the camera one. It seems that the camera one just kills the microphone one.

Chrome's behaviour is to first ask for Microphone, then for Camera.
It seems that prompt() in webrtcUI.jsm doesn't stack things.
Summary: getuserMedia doorhangers are overwritten → getuserMedia doorhangers are overwritten by subsequent calls to getUserMedia
Component: WebRTC → Device Permissions
Product: Core → Firefox
Whiteboard: [getUserMedia]
I can reproduce it in 40: http://jsfiddle.net/u1kf7yab

In 41+, I get different, also poor, behavior: Only the microphone prompt appears, and the video gUM request fails with NotFoundError.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861716
You need to log in before you can comment on or make changes to this bug.