update service worker importScripts() to latest spec

RESOLVED DUPLICATE of bug 1465670

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1465670
4 years ago
11 months ago

People

(Reporter: bkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

See:

  https://github.com/slightlyoff/ServiceWorker/issues/730#issuecomment-132192995
  https://github.com/slightlyoff/ServiceWorker/issues/642#issuecomment-137631700

I think the main change here would be to allow importScripts during the install event in addition to top level script evaluation.
I'm not sure if my interpretation in comment 0 is correct.  We should investigate.  I don't think this is very high priority, though.
Note, there is a new spec issue about whether we really want to do this or not:

https://github.com/w3c/ServiceWorker/issues/1021
(Reporter)

Updated

2 years ago
No longer blocks: ServiceWorkers-postv1
Priority: -- → P3
(Reporter)

Comment 3

11 months ago
I ended up fixing this in bug 1465670.  I forgot this bug existed.
No longer blocks: ServiceWorkers-compat
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1465670
You need to log in before you can comment on or make changes to this bug.