Performing a Simple Search results in the message "invalid column names: relevance desc"

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: bugzilla, Assigned: glob)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted image sortorder.png
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.13 Safari/537.36

Steps to reproduce:

Perform a Simple Search on bugzilla.mozilla.org.


Actual results:

A green box appears at the top with the message "The custom sort order specified contains one or more invalid column names: relevance desc. They have been removed from the sort list."


Expected results:

Results should be sorted by relevance or some other sensible column.

Updated

4 years ago
Assignee: query-and-buglist → nobody
Component: Query/Bug List → General
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
(Assignee)

Comment 1

4 years ago
looks like we're checking for invalid columns too early - the results are actually sorted by "relevance desc".
Assignee: nobody → glob
Status: UNCONFIRMED → NEW
Component: General → Search
Ever confirmed: true
(Assignee)

Comment 2

4 years ago
- determine if we need to display an error after we've populated $search->COLUMNS->{$field}->{name} not before
Attachment #8657682 - Flags: review?(dkl)
Comment on attachment 8657682 [details] [diff] [review]
1202147_1.patch

Review of attachment 8657682 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #8657682 - Flags: review?(dkl) → review+
(Assignee)

Comment 4

4 years ago
Total 3 (delta 2), reused 0 (delta 0)
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   59b9064..8ab0d67  master -> master
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.