[Mac] SVG sub-integer stroke-width produces random lines inside shape

RESOLVED DUPLICATE of bug 1198307

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1198307
3 years ago
3 years ago

People

(Reporter: Scott D, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8657473 [details]
broken2.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/600.8.9 (KHTML, like Gecko) Version/8.0.8 Safari/600.8.9

Steps to reproduce:

Try to render the attached broken2.html file, which includes a very simple embedded SVG, on a Mac. I am testing with the latest OS X 10.10.5, in case it matters.

The SVG renders as expected on Firefox <= 38. On Firefox 39+ (including the latest I tried, Firefox 40), it renders random lines inside the rectangle, so this appears to be a regression.

These random lines should be immediately apparent if you have a NON-Retina display. If you do have a Retina display, you may need to press "Command--" to reduce the zoom factor a couple of times before the lines will appear.


Actual results:

The requested rectangle is rendered, but there is an extra random grid rendered inside the main rectangle. The "stroke-width" of 0.5 on the <rect> seems to be what causes the problem. If I change the stroke-width to 1, the issue goes away and the rectangle renders as expected, regardless of the zoom.


Expected results:

Firefox should render a plain rectangle without any grid inside.
(Reporter)

Comment 1

3 years ago
Created attachment 8657475 [details]
retina-display-zoomed-out-once.png

Attached a screenshot showing the rendering on a Retina display, zoomed out exactly once with Command--.
(Reporter)

Comment 2

3 years ago
Oops. In the process of trying to categorize this issue correctly, I realized that I was looking in the wrong component. After looking there, I found that this is a duplicate of #1198307.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1198307
You need to log in before you can comment on or make changes to this bug.