[NewHomescreen]Cannot move an icon to make it become the last icon of last page.

VERIFIED DUPLICATE of bug 1218329

Status

VERIFIED DUPLICATE of bug 1218329
3 years ago
3 years ago

People

(Reporter: huayu.li, Assigned: cwiiis)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8657507 [details]
logcat3.txt

[1.Description]:
[Aries][v2.5][NewHomescreen]Cannot move an icon to make it become the last icon of last page.
Found at:16:17
see attachment:logcat3.txt, AriesKK_V2.5.3GP.

[2.Testing Steps]: 
1. Move an app to make it become the last icon of last page.

[3.Expected Result]: 
1.Can move an icon to make it become the last icon of last page.

[4.Actual Result]: 
1.The icon cannot be moved.

[5.Reproduction build]: 
Device: Aries KK 2.5[Affected]
Build ID               20150901190039
Gaia Revision          c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gaia Date              2015-09-01 17:03:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e47423c019643792e6de894cfcee598dead4d3ba
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150901.182105
Firmware Date          Tue Sep  1 18:21:13 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
16592
(Reporter)

Comment 1

3 years ago
Created attachment 8657508 [details]
Flamekk_v2.5.3gp
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected

Updated

3 years ago
QA Whiteboard: [COM=New Homescreen]
(Assignee)

Comment 2

3 years ago
Seems to be the wrong video attached?
Flags: needinfo?(huayu.li)
(Reporter)

Updated

3 years ago
Attachment #8657508 - Attachment is obsolete: true
Flags: needinfo?(huayu.li)
(Reporter)

Comment 3

3 years ago
Created attachment 8657734 [details]
AriesKK_V2.5.3gp

Update attachment.
(Assignee)

Comment 4

3 years ago
Heh, this is something I fixed specifically before merging, I guess I must've broken it at some point... Will have to make sure this is tested when I fix it.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Keywords: regression
Created attachment 8657828 [details] [review]
[gaia] Cwiiis:bug1202190-new-homescreen-drop-icon-at-end > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Comment on attachment 8657828 [details] [review]
[gaia] Cwiiis:bug1202190-new-homescreen-drop-icon-at-end > mozilla-b2g:master

Fixed regression, added unit tests to prevent it appearing again.
Attachment #8657828 - Flags: review?(gmarty)
Comment on attachment 8657828 [details] [review]
[gaia] Cwiiis:bug1202190-new-homescreen-drop-icon-at-end > mozilla-b2g:master

LGTM with a nit/question left on GH.
Attachment #8657828 - Flags: review?(gmarty) → review+
(Assignee)

Comment 8

3 years ago
Fixed and merged, thanks: https://github.com/mozilla-b2g/gaia/commit/d068ae4d95a291396abd6ed40b8a125a9b5b5a51
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Blocks: 1191745
(Reporter)

Comment 9

3 years ago
This issue has been verified as pass in latest build of AriesKK_V2.5
Rate:0/5

Device: AriesKK_V2.5[pass]
Build ID               20150909010407
Gaia Revision          e69f2c86b931b723dd405115e33a1d02e6c5f5e6
Gaia Date              2015-09-08 20:39:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/02b255caee93ac6fdfb2384ec90d748ab112ef27
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150909.002540
Firmware Date          Wed Sep  9 00:25:48 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
(Reporter)

Updated

3 years ago
status-b2g-master: affected → verified

Comment 10

3 years ago
Found this issue again on the latest build.

Drag an app that is not in the last page will recreate this bug. App will become the first icon on top of the home screen instead of the last icon. 

[Build Info]
Build ID               20151025085903
Gaia Revision          1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gaia Date              2015-10-23 17:01:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d53a52b39a95dced722cca90ac74529b66dd5253
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151025.081846
Firmware Date          Sun Oct 25 08:18:54 UTC 2015
Bootloader             s1
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Whiteboard: [systemsfe]

Comment 11

3 years ago
Nominate blocking for decision.
blocking-b2g: --- → 2.5?
(Assignee)

Comment 12

3 years ago
This works for me on master - possibly you were encountering bug 1218329?
Flags: needinfo?(huayu.li)
Blocker if not a dupe.
blocking-b2g: 2.5? → 2.5+
(Reporter)

Comment 14

3 years ago
Hi chris,
I can reproduce this issue as Teri said: "Drag an app that is not in the last page will recreate this bug. App will become the first icon on top of the home screen instead of the last icon. "

Device:AriesKK_V2.5
Build ID               20151025150204
Gaia Revision          1c6628ed1e40575e5ec3669ab6ef389d4ebeea65
Gaia Date              2015-10-23 17:01:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d53a52b39a95dced722cca90ac74529b66dd5253
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151025.184556
Firmware Date          Sun Oct 25 18:46:08 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(huayu.li)
(Assignee)

Comment 15

3 years ago
Could you provide a video of this issue? Either that, or *very* specific STR?

I can drag icons all over the place and not reproduce this. I can reproduce bug 1218329, but that will be fixed imminently.
Flags: needinfo?(huayu.li)

Comment 16

3 years ago
This could be related to bug 1218329. Will check again after the fix has landed for that bug.
(Reporter)

Comment 17

3 years ago
Created attachment 8679221 [details]
Arieskk_v2.5.3gp

Provide the video on aries.
Flags: needinfo?(huayu.li)
(Assignee)

Comment 18

3 years ago
I think this will be fixed by bug 1218329, leaving for Teri to check as per comment #16.

Comment 19

3 years ago
Yep, verified fixed by bug 1218329. Thanks Chris and Alissa. 
Changing status back to verified.

Build ID               20151027221526
Gaia Revision          a26eadc5e1133d5112b6cbc10badbb7670a1090f
Gaia Date              2015-10-27 17:36:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2b333a1d94e805a59c619ee41a6dec7fdcce505d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151027.213419
Firmware Date          Tue Oct 27 21:34:27 UTC 2015
Bootloader             s1
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 20

3 years ago
Wrong status. 
Change to duplicate.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1218329

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.