[Download Manager]View the picture when it is downloaded completely, it will go back to the webpage where the picture is downloaded.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Download
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: Lancy(Leave from Mozilla), Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-2])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8657551 [details]
AriesKK_v2.5_logcat.txt

[1.Description]:
[AriesKK v2.5][Download Manager]Tap the notification when the picture is downloading from internet,  and view the picture when it is downloaded completely, it will go back to the webpage where the picture is downloaded.
See attachments:AriesKK_v2.5_logcat.txt and AriesKK_v2.5_video.3gp.
Occurrence time:04:13

[2.Testing Steps]: 
1.Connect the network and download a picture from internet.
2.Tap the notification when the file is downloading.
3.View the picture when it is downloaded completely in downloads list.

[3.Expected Result]: 
3.The preview should be shown.

[4.Actual Result]: 
3.It will go back to the webpage where the picture is downloaded.

[5.Reproduction build]: 
Device: Aries KK v2.5 (Affected)
Build ID               20150905112803
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150905.105729
Firmware Date          Sat Sep  5 10:57:37 UTC 2015
Bootloader             s1

Device: Flame KK v2.2 (Unaffected)
Build ID               20150905032501
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d3cb4f28c735
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.065255
Firmware Date          Sat Sep  5 06:53:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test

[8.Note]:
Tap notification when the file is downloading on FlameKK v2.5 build, the Browser will exit automatically and user cannot enter downloads list.
(Reporter)

Comment 1

3 years ago
Created attachment 8657552 [details]
AriesKK_v2.5_video.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Keywords: regression
Keywords: regressionwindow-wanted
> Tap notification when the file is downloading on FlameKK v2.5 build, the Browser will exit automatically and user cannot enter downloads list.

Increasing Flame's memory can work around this issue and with the workaround this is reproducible on Flame 2.5.
QA Contact: pcheng
Summary: [AriesKK][Download Manager]View the picture when it is downloaded completely, it will go back to the webpage where the picture is downloaded. → [Download Manager]View the picture when it is downloaded completely, it will go back to the webpage where the picture is downloaded.
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150622170244
Gaia: c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko: 2ab4034b2cc1
Version: 41.0a1 (2.5 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken
Device: Flame
BuildID: 20150623190325
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 5a3ee6baf143
Version: 41.0a1 (2.5 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working Gaia First Broken Gecko - no repro
Gaia: c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko: 5a3ee6baf143

Last Working Gecko First Broken Gaia - repro
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 2ab4034b2cc1

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/c4d3b8fd78bcd7eff1b127060ec6490a891b7a35...eb0d4aefa62b20420d6fa0642515a110daca5d97

This issue is caused by changes made in Bug 1144132.
Blocks: 1144132
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Gerry can you please take a look at this?  The author of the patch that caused this regression is no longer working on the project.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(gchang)
Hi Fred,
Can you help on this?
Flags: needinfo?(gchang) → needinfo?(gasolin)

Comment 6

3 years ago
@Aus could you help on this?
Flags: needinfo?(gasolin) → needinfo?(aus)

Updated

2 years ago
Flags: needinfo?(aus)

Comment 7

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.